Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting & Designing Networks (https://www.badcaps.net/forum/forumdisplay.php?f=36)
-   -   Marvell Gigabit controller stuck at 100Mbps (https://www.badcaps.net/forum/showthread.php?t=82503)

shovenose 02-08-2020 01:15 PM

Marvell Gigabit controller stuck at 100Mbps
 
1 Attachment(s)
My NAS is a Windows 10 1909 64-bit PC running on an EVGA Z68 FTW motherboard which uses a Marvell 88E8057 network controller.

The problem is that the network connection is stuck at 100Mbps. That really sucks when I'm trying to move large files around.

I tried a few different network cables, I tried moving it from my Asus router to my Netgear switch (both of which are obviously gigabit).

Driver version is 12.10.16.0 which was automatically installed by Windows. EVGA's website lists an older version than that. Marvell's website lists 12.10.17.3 but when I try to install it, it says "a newer version is already installed"

Not sure what the next step is besides putting in a PCI-E NIC which I really don't feel like doing.

RJARRRPCGP 02-08-2020 01:55 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Did you try other cats? LOL.

diif 02-08-2020 02:03 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
It wouldn't bee the first time a Windows driver has screwed up an ethernet connection.
Uninstall the Windows driver and install the one from the EVGA website.

RJARRRPCGP 02-08-2020 04:33 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
I would be pissed and think of wiping the drive and reinstalling Windows.

Especially Windows 10 with Windows Update errors.

shovenose 02-08-2020 05:05 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Quote:

Originally Posted by RJARRRPCGP (Post 941184)
Did you try other cats? LOL.

Yes, I borrowed my friends furry friend and tried to shove it in the second Ethernet port because the motherboard has too. Unfortunately, I got a hissing noise and some scratches, and my friend is now angry at me.

Per Hansson 02-09-2020 03:30 AM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Did you try setting the speed to 1000Mbps manually?
It's quite common to have auto negotiation issues with gigabit Ethernet.
Intelligent switches and most NICs have some options to change to alleviate that

shovenose 02-09-2020 03:24 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Quote:

Originally Posted by Per Hansson (Post 941303)
Did you try setting the speed to 1000Mbps manually?
It's quite common to have auto negotiation issues with gigabit Ethernet.
Intelligent switches and most NICs have some options to change to alleviate that


Nope, in the drop down on windows I can't pick gig. Only 100 or autonegotiate.

stj 02-11-2020 02:39 AM

Re: Marvell Gigabit controller stuck at 100Mbps
 
try a linux livedisk,
try a new cable - check it has all 8 wires connected.
100mb does not use all 8, 1000 does.

if you still cant get it going, check the transformer on the motherboard and any asociated ceramic caps.
if the chip cant detect all 8 lines it will not run at 1000.

incidentally, most marvel chips can run a cable test and even have a built-in TDR function.
try tracking down the software - i think asus used to supply it with the top-end athlon boards.

SMDFlea 02-11-2020 09:31 AM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Marvel have a DOS diag utility,and a Virtual cable tester . https://www.marvell.com/support/downloads.html

Topcat 02-15-2020 12:48 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
Cable would be my #1 suspect as well...I've ran into this a lot over the years.

dragos2009 02-16-2020 06:38 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
i would sugest getting a q tip + IPA to clean the ethernet connector pins i had problem with connection cause of debris on the pins

CapLeaker 02-23-2020 02:53 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
maybe the pins are bent in the marvel Ethernet port? seen that and the actual port being worn out (from plugging in and out too many times). Other than that I guess drivers. Maybe a boot linux from a stick and retest.

exy1 01-19-2021 11:47 PM

Re: Marvell Gigabit controller stuck at 100Mbps
 
simple way to test
1 just plug same cable to laptop and check speed ( don't change any setup)
if laptop works on 1gbps
2 boot from live cd from NAS ( Any win 10 live cd-dvd-USB works)
if not going on gbps check network port pins are straight and clean ( use alcohol and q-tips to clean it.
If Live cd works then some thing wrong set in network card drive advance settings.


All times are GMT -6. The time now is 03:07 AM.

Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.