Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (https://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   LG 50PC56 keep burn Buffers Boards (https://www.badcaps.net/forum/showthread.php?t=106093)

gatto 05-04-2022 01:35 AM

LG 50PC56 keep burn Buffers Boards
 
Hi, I’m new to the forum and this is my first post, so thank you in advance to having me, I have the fallowing problem, could someone please help

I have this LG 50PC56 which not display image on screen
I have already change Y-SUS and buffers 2 times! But this TV keep burning my buffers boards!
When I do install the new Buffers board I been able to see only the top half part of the screen for about 10 min, and then it blow up again! The IC get very hot and I saw some smoke come out from it, so now I have another set of buffers burn out
My question it is: I disconnect the buffers board from Y-SUS and I notice that it get very hot anyway at the point to burn your fingers! Is it normal? Does those card get electricity from the screen/panel? Or do I have a faulty panel?
I have spend money on tried to repair this TV, I change main board, Y-SUS and Buffers plus T-com what else could it be? Please if someone could address my on the right direction…Thank you in advance

Biruslapio 05-04-2022 05:32 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Only top half of the panel working when a full working set of Y-SUS, buffers, logic and main board is installed, looks like defective panel, some voltage is leaking where it isn't supposed to be, these buffer chips deal with very high voltage, 500Vpp signal so it's not a good idea to mess with them with the TV still on, and when they fail short they tend to damage the Y-SUS IGBTs.

If there is not proper connection only half of the panel would be visible, but since it's been through some swaps I assume every cable is properly plugged in.

gatto 05-04-2022 02:10 PM

Re: LG 50PC56 keep burn Buffers Boards
 
Hi, thank you for reply!!
I was going to give up I have take out all boards with the intention to sell them in eBay to recover some money! But then I change my mind I did put everything back as I had the idea of desolder a good IC from one blowed set of buffers boards and solder it in stead of the one that I know was burned on the last board I brought..I did install it and now I got very dark screen with large set of moving vertical line, that I assume it is the no signal logo, if I press menu on remote I can see the set of line getting bigger as when the menu is open on same channel I get sound but not all. I touch the IC and is not hot, no one of them get hot now! Before they did get very hot even when disconnected, but attached to the screen ribbon only, now they donít! I was wandering why? Anyway If the screen was faulty wouldnít I get what I have previously describe? The buffers doesnít work but at least they donít get hot, I know because if I disconnected them will do the same, the only differenze from what describe before is that now the IC on buffers donít get hot!
My question are:
Could be the dark screen because of faulty Z sus? And the line because of faulty buffers? I was quite sure that the fault was on the panel but now I donít know anymore! The only thing I did is take out all board and put back again and solder one IC from another buffers board (which is not working)

What test can I do next? Is possible to know if the screen is faulty with some test? How can I test the Z sus?
I only have voltmeterÖIf you have any suggestion will be great! Thank you

Biruslapio 05-04-2022 04:47 PM

Re: LG 50PC56 keep burn Buffers Boards
 
Please provide pictures of these vertical lines.

Yeah jumping to a panel failure diagnose that quick was wrong, it was because you said that you tried multiple boards, but you can test them.

https://www.youtube.com/watch?v=Z9pGXQcxaIM Go to 06:30, you see how he probes the board, positive lead on the big floating ground, and negative on the screen output pins, there should be megaOHMs levels of resistance if the board is good, when it shorts it's usually 30 OHMs or less.

When the Z-SUS fails the picture gets really dark, with a purple haze but still visible, there woudn't be vertical lines/artifacts and such.

gatto 05-05-2022 02:14 AM

Re: LG 50PC56 keep burn Buffers Boards
 
5 Attachment(s)
Good morning, thank you! Donít worry, I would have say the same from what Iím describe to you! I was assuming the same and itís still considerable. I saw the video you sent, but my set is different, and the board is not the same, if I know where are that testing point on my board I would check it. I send you a picture of my board, probably you know that. But as I said, Iím pretty sure that my fix didít work, Is not easy (at least for me) desolder a chip without damage it as itís cover in silicon, I been look for new IC but is more expensive than used board!
As I said if I do disconnect the buffers from Y-sus I have the same result which is a dark screen as you can see on the picture I sending to you..

gatto 05-05-2022 02:32 AM

Re: LG 50PC56 keep burn Buffers Boards
 
4 Attachment(s)
If I disconnect the buffers board I got this floating on the screen the big one if I press menu

Biruslapio 05-05-2022 09:51 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Look at the metal interposer between the Y-SUS and buffers, one of them is the floating ground, it needs to have all the screws in and tight, they're missing everywhere, that will lead to sparks, killing the buffer boards.

Exchanging the IC is VERY difficult and a task better left to professional technicians, even a little micro offset will short pins and blow the IC again, it's very fragile and easy to rip the traces from the board.

To test your board for shorts you place the positive lead on the big pad where the two screws go for each board, disconnect the panel cables, and use the other side that is not covered in glue.

You can't have missing screws on sustainboards in a plasma, the Y-SUS is also missing, this will either kill boards or make the TV produce excessive buzzing due to poor grounding.

gatto 05-06-2022 01:08 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Good morning! Thank you, i didn't know about screws!
Do you think that my problem has been the missing screws tho... If so I can’t justify my ignorance! I could have read and asked more question before start working on this television! So I fucked 2 set of Buffers because of it!! What shame of me!

Now, do you think is still possible to get this set working again, on your opinion could be that as result of missing screws something also now could be broken? if I get new Buffer with all the screw on It will work? Do you think that the screen/panel is still good?


I do agree it's hard to change IC, but I consider myself good in soldering as I have replace GPU on videocard, I did reballing etc, but on theory as you can see I’m not that good ;-)

Today I change the T-COM, I reinstall the old one and the screen is not dark anymore! I have the same output but the screen now is brighter I will add a picture…

Biruslapio 05-06-2022 09:29 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Test the buffers before anything else like I've sugested.
The panel is fine, it's very resilient to damage.

gatto 05-07-2022 05:08 AM

Re: LG 50PC56 keep burn Buffers Boards
 
2 Attachment(s)
Hi, sorry for late reply but I could'n do it before. The buffer are not good! My worry is that if I bay another set of board will blow again! Are you sure that the missing screw was the reason of blow it up? The picture are take after I replace T-COM which the output is the same but much brighter. I assume that I brought a faulty T-COM tho, let me know what you think! You help is much appreciate. Thank you

chrismurphy 05-07-2022 07:14 AM

Re: LG 50PC56 keep burn Buffers Boards
 
those lines are bad connections on the buffer to panel , no wonder they blow up
your not installing the flex cables correctly

gatto 05-07-2022 07:52 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Hi, thank you! I have a look at it, it's properly installed but you are right as I notice that 1 pin is damage on the ribbon! I have to find a new one tho. I will update as soon as I got both ribbon and Buffers. bro, you are great!

gatto 05-07-2022 08:37 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Ok, but I did check the connection and look ok! If I do install a new set of buffers how do I know that the connection are bad without switch the set on? To me the connector look ok I pushed them well inside and the slap close well..Can they be damage? Thank you

Biruslapio 05-07-2022 09:44 AM

Re: LG 50PC56 keep burn Buffers Boards
 
You still did not test the buffers with the multimeter.

Put all 12 screws, there's no going wrong with that.

Looking at that latest photo, first try a buffer board swap, then if it still has bad picture, the problem lies on the Y-SUS.

nomoresonys 05-07-2022 09:56 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Quote:

Originally Posted by gatto (Post 1131482)
Hi, thank you! I have a look at it, it's properly installed but you are right as I notice that 1 pin is damage on the ribbon! I have to find a new one tho. I will update as soon as I got both ribbon and Buffers. bro, you are great!

probably won't have any success til this is fixed.

Biruslapio 05-07-2022 01:59 PM

Re: LG 50PC56 keep burn Buffers Boards
 
By ribbon it means the cables that goes from Y-SUS to buffer and top to bottom boads, or the panel contacts?
Edit: a quick search reveals that it's those small cables, they do not look properly fit on those pictures on post #5, and if one of the wires came out the picture will not be fine.

gatto 05-07-2022 06:11 PM

Re: LG 50PC56 keep burn Buffers Boards
 
I didn't read properly your message sorry, I meant the ribbon from T-com to Y-SIS, but you were talking about the ribbon from the screen, sorry my mistake! what In photo 5, is the cable push in as far as it goes! It doesn't go any furder than that bro, I can guaranty you.

Which wires come out of picture? I don't understand what do u mean?

I didn't test the buffers with a voltmeter because (again) the IC get very hot which mean that is not good innit? If I had only a suspicion that was working I would have done it, but if you think I should I will

I have 2 Y-SIS I did already swap them, how can it be the Y-SIS? Could be, only if both were faulty, I brought one, which did'n solve the problem, I told the seller the that it wasn't working and he sent me another one, (he let me keep the other one) when I get the second one, I had the same output so I did assume that the fault was not on the Y-SIS....

Biruslapio 05-07-2022 07:25 PM

Re: LG 50PC56 keep burn Buffers Boards
 
There are some buffer chips on the Y-SUS that bridges the signal from logic board to the Y-buffers, very rarely they fail, but let's focus on the buffer boards first.

If the IC is getting abormaly hot even with the buffers properly installed then it's faulty.

If the panel connectors are correctly lined up, all those horizontal black lines/bars are the result of the buffer IC output being damaged, they fail either short or open, when it shorts the whole picture gets grainy and triggers an overcurrent shutdown.

I suppose replacement buffers are on the way?

gatto 05-08-2022 01:23 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Good evening bro, yes they get very hot even with the buffers properly install! I will order a buffers set tomorrow, I didn't order it before because I wonted to be sure that the panel is good before buy it, I have already spend a considerable amount of money...I will have to buy used parts now from ebay as I'm short of money! Hopefully I will get the buffers this week and before installing it I will consult you, if that's ok
Thank you in advance, talk to you soon

gatto 05-09-2022 01:26 AM

Re: LG 50PC56 keep burn Buffers Boards
 
Quote:

Originally Posted by nomoresonys (Post 1131505)
probably won't have any success til this is fixed.

I will change that as well! Thank you


All times are GMT -6. The time now is 05:17 PM.

Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.