Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting Power Supplies and Power Supply Design (https://www.badcaps.net/forum/forumdisplay.php?f=32)
-   -   APC Smart UPS 620 not working (overload light on) (https://www.badcaps.net/forum/showthread.php?t=96369)

Dannyx 06-04-2021 09:02 AM

APC Smart UPS 620 not working (overload light on)
 
3 Attachment(s)
Good day folks. It feels like absolute ages since I've posted anything here, mostly because I don't get anything interesting to work on here (a-holes keeping it all to themselves >_>), so I have to come up with my own ways of making time fly by quicker, so here's something: I found this APC UPS which seems decent enough to keep, or at least to keep me entertained and awake as I attempt to fix it.

The board looks clean - no visible damage whatsoever. I also managed to find the schematic for it, so I don't go around blindly replacing all the caps, which I doubt is the cause of failure to begin with.

I didn't dare plug it into the mains, but it should work on its own off the battery, according to the manual, so I used a fresh one to test. When I hit the button, I get a beep, I hear some relays closing and that's it. After a little while, the relays go off again. You can try doing this all day long with no change. Occasionally, the overload LED will come on and it will also beep continuously, but I've yet to figure out if it happens at random or there's a pattern to this LED coming on. I also don't hear any specific noises that would indicate the inverter part is working: no buzzing or humming from the transformer and no squeals or ringing noise from the board.

To try and cut the story somewhat short and skip the routine procedures I always go through when diagnosing, like look for shorts or burnt components, I THINK the problem lies somewhere with U9 on page 6, as it appears to be responsible for driving the 8 transistors (4 in my particular unit) that in turn switch the transformer to generate an output. No U9 means no output. Unfortunately this is where I got stuck. There's no info on this part, so I don't know how it operates. I don't have a scope, so I have no way of checking if U9 is doing anything or not. It gets its supply on pin 1 as it should, no problem there. It seems it's driven directly by U1, the MCU, on pins LSB and MSB, though I have no way of checking if this actually happens or not. Then there's that -8v rail below it. If I measure it with respect to GND (the negative battery terminal), I get around -10v on C50 (that's the negative leg before D28). If I put the red probe AFTER D28, I only get around -4v...not sure what this means and what this voltage is for. I'll probably try pulling out C49, though every cap I've tested so far seems to be within spec, since I tried several of them, hoping they're read out of spec, but ended up putting them back on the board, since they checked fine on my capacitance meter.

This might be a good time to bring up that I'm not sure if the capacitance reading can show up fine on a regular multimeter, but the capacitor may still be out of whack enough to cause malfunctions somehow (like ESR ???). I don't have an ESR meter at work, though I'll bring my own from home if it turns out I've exhausted every possibility....

I took a lot of different measurements all over the board, both with and without the battery, but it would take WAY too much space to list them all, so let's discuss as suggestions come in. Any thoughts would be greatly appreciated.

sam_sam_sam 06-06-2021 07:45 PM

Re: APC Smart UPS 620 not working (overload light on)
 
I would start with just replacing the low UF capacitors under 100 because I found that most of the time the ESR values read high

Dannyx 06-06-2021 10:15 PM

Re: APC Smart UPS 620 not working (overload light on)
 
Quote:

Originally Posted by sam_sam_sam (Post 1050751)
I would start with just replacing the low UF capacitors under 100 because I found that most of the time the ESR values read high

This would imply that capacitance can read fine, even though ESR is high(ish). I must admit I haven't studied ESR that much - I know what it is in general, but it's just a term that's thrown around when it comes to caps and is simply known to be "bad", but I don't know much about the physics behind it.

CapLeaker 06-07-2021 04:53 AM

Re: APC Smart UPS 620 not working (overload light on)
 
could be also a transistor of some sort loosing its hfe gain.

Dannyx 06-07-2021 05:00 AM

Re: APC Smart UPS 620 not working (overload light on)
 
I think the only ones that may pose such a problem are Q14 through to 21 on page 6, at the very bottom, even though I only have 4 of them (so 2 on each pair), not 8. Those appear to drive the transformer. I'm not getting squat - not even the faintest noise....

Speaking of transistors, I don't understand the operation of the circuit directly above that on page 6, with Q12 and Q13. The two tags on the left ("brown" and "blue") come from the transformer, so I assume they use the body diodes of the transistors to rectify it, though why are they using transistors in the first place to do that and not just the diodes D21 through to D24 ? Is this some sort of standard building-block circuit that I'm not seeing ? It would sure help enrich my knowledge :D Like when I see a coil next to a transistor and a diode, I can tell that's a buck/boost converter. If I see a transistor, a transformer and an optocoupler, that's probably a SMPS. Same with this thing: can someone look at that part and go "oh, that's a......"?

Dannyx 06-08-2021 07:31 AM

Re: APC Smart UPS 620 not working (overload light on)
 
2 Attachment(s)
Ok guys, here's the situation. I busted out my ESR meter today, which isn't anything too professional by any stretch of the imagination (probably cost me around 15$ when I got it), but has been enough to point me in the right direction on several occasions.

I'd say these results are pretty clear: ALL of the 22uF caps show rather high ESR ratings, despite the capacitance being tolerable. (Hope you can see that picture alright) It's not just because of my Aliexpress meter - I ran the tests several times and even tried measuring some "good" caps and they read around 1.x ohms which is infinitely better. My favourite one has to be that 99ohm one :D

Replacing this bunch will probably solve the problem. I don't have them on hand right now, so it will have to wait, but I will keep you posted :)

redwire 06-08-2021 01:45 PM

Re: APC Smart UPS 620 not working (overload light on)
 
For your time and money, just outright replace all the electrolytic capacitors.
These UPS are powered 24/7 and are warmer running over 35C so the caps just dry out. The batteries are worth more than the entire unit lol.

The circuit is centered around a big iron-core transformer, it puts out about 18VDC when mains are present, and during a power fail the mosfets start switching battery voltage to the transformer at 50/60Hz. So the transformer is being used in reverse then.
There is also a (relay) stepped autotransformer to boost or drop mains to deal with sags and surges.

I think the battery charger is LM2575 with two 330uF 25V output capacitors C41, C44.
Did you replace these with some small crappy tiny parts? The picture shows something real small compared to the silkscreen.

Dannyx 06-08-2021 01:49 PM

Re: APC Smart UPS 620 not working (overload light on)
 
Haven't replaced anything yet - that pile in the picture is all the 22uF caps on the board, so yes, I'll be replacing all of them. The 330uF ones read fine, so I left them for now.

I scored a battery for free, that's why I'm bothering with it, plus APC seems decent enough. I already tossed several others which were either too damaged or too low spec/quality to be worth bothering with.

Dannyx 06-11-2021 12:35 AM

Re: APC Smart UPS 620 not working (overload light on)
 
Ok folks, here's the situation: I replaced all those caps and it still doesn't work, however it does manage to start up sometimes now. If I keep trying it over and over, occasionally the lights will come on and I get an output, so the inverter is fine, albeit under no load. It could be because the caps are some BS ones I got from China for like 1$ for 100pcs that I had laying around and had no better use for, so that could be a factor, or there's still something else that's gone bad....

I also noticed that -8v rail reads slightly higher at -9.5, which may or may not throw off the LM324 opAmp...can D28 play a part in this ???

Dannyx 06-11-2021 03:43 AM

Re: APC Smart UPS 620 not working (overload light on)
 
Ok, guess what: it appears to work now. After I had checked just about every component I could think of that could be responsible for the fault, to the best of my knowledge, I gave the board a good whack right where the relays are and the next time I tried it, it actually turned on fine....

I thought maybe one of the relays got stuck, so to confirm, I pulled the battery and tried a cold start again. Just like before, it didn't work: I got the same two clicks but nothing else. I then tried hitting the board again and it worked once more. I tried it one more time to confirm my results and the same thing happened. I thought I should just go ahead and replace the relays, but then I also noticed that if I shut down the UPS from the power button, before disconnecting the battery, it turns on fine the next time, whereas if I pull the battery while the inverter is running, the next cold boot is likely to be unsuccessful until I whack the relays again. It's probably down to the energy in the coil decaying really slowly when I pull the battery while it's running, causing the armature to not quite fully return to its resting state, whereas when the board does it, it cuts the power all in one go.

To sum up: probably relay problems. I should replace them, but I'm not planning to use this unit any time soon, so I'll just leave it like this and it's good enough for me. We can call this case closed for now. Cheers guys.

petehall347 06-11-2021 04:11 AM

Re: APC Smart UPS 620 not working (overload light on)
 
check / replace/ fit relay flyback diodes . if none are fitted relay driver transistors might be damaged .

Dannyx 06-11-2021 04:15 AM

Re: APC Smart UPS 620 not working (overload light on)
 
Quote:

Originally Posted by petehall347 (Post 1051745)
check / replace/ fit relay flyback diodes . if none are fitted relay driver transistors might be damaged .

They already exists: D35, D36, D39, D40. I'm sure they wouldn't have made such an oversight when designing the thing, though it's true I didn't pull them out to check them individually...


All times are GMT -6. The time now is 06:25 AM.

Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.