Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (https://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   LG 42" Plasma Model 42PG20R-AFB (No picture) (https://www.badcaps.net/forum/showthread.php?t=77506)

angelos 07-06-2019 08:32 AM

LG 42" Plasma Model 42PG20R-AFB (No picture)
 
6 Attachment(s)
HI guys,
I have another beast of a TV and lack the knowledge to fault find which board to look at.
When starting this TV you hear a click and Vs and Va come up as per plasma label but there is no pre-charge and no picture. As a matter of fact the Y-SUS and Z SUS boards are not getting the slightest heat on the heat sinks meaning they are not being driven at all.
The led on front panel shows TV is in the on state and when I press vol+ or Vol- the standby light flickers indicating that the main is at some extent operating.
At this point i can suspect any board especially the logic control board which has only one green light with the other two being off or perhaps something wrong with the main board.
Unlike the Samsung where you can short out two pins on the control board and force the controller to generate a test pattern to the plasma boards on the LG i know nothing like that.
Any fault finding tips would be greatly appreciated.

Regards
Angelos

diif 07-06-2019 08:39 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
A photo of the logic board, there are usually a couple of holes that are bridged for the test pattern.

angelos 07-06-2019 04:09 PM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Ok will upload when able to. Thanks..

Andrew F. Ali 07-07-2019 01:25 PM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Quote:

Originally Posted by angelos (Post 904363)
Ok will upload when able to. Thanks..

Clear focused close-up shots.

angelos 07-10-2019 04:02 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
2 Attachment(s)
Here are the picture of both sides of the logic board as discussed.

diif 07-10-2019 04:10 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Just to the right of the sticker, EXT_AUTO_GEN.

angelos 07-10-2019 11:47 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Great. I will bridge the two pins and see what happens...

tvtimmy 07-10-2019 11:50 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
You also have to unplug the ribbon cable from the mainboard to the logic control board.

angelos 07-11-2019 03:27 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Will do...

angelos 07-13-2019 06:40 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Ok, i shorted the auto gen pins and removed the LVDS cable to the logic board. Switched on set and nothing still no panel drive.
Where do i go from here? I measure no shorts on Vs, Va etc. Those mosfets i tested all had no shorts on their pins.

tvtimmy 07-13-2019 07:08 AM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
You will have to test the igbt's in diode mode. Removing them is best when testing.

angelos 07-13-2019 02:41 PM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
Have you had an igbt go open circuit? How do we test those since some transistors do not get triggered by the small voltage the multi metet produces or am i wrong?

tvtimmy 07-13-2019 04:36 PM

Re: LG 42" Plasma Model 42PG20R-AFB (No picture)
 
5 Attachment(s)
Yes, I have. I have a cheap transistor tester that I use, after testing with my DMM. See pics.

Sometimes original bad igbt's read like this too.


All times are GMT -6. The time now is 12:52 AM.

Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.