Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (https://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   TCL 75R615 has sound, no backlight (https://www.badcaps.net/forum/showthread.php?t=101292)

thetonywarren 11-29-2021 05:31 PM

TCL 75R615 has sound, no backlight
 
Have had this TV since June 2019, worked fine till today. Daughter was watching it and made a noise and went dark. I unplugged, left off then powered back on, no change. You can see the image with flashlight test, but has high pitched noise/whine and no backlight whatsoever......I also tried a factory reset with the reset button on the back. Any ideas where I should start troubleshooting? Im pretty good with soldering iron and multimeter, but I dont have any documentation on this TV so I dont know where to start.

dskall 11-29-2021 07:32 PM

Re: TCL 75R615 has sound, no backlight
 
I would start at power board. Sounds like shorted component causing the led driver to make noise. Need some pictures of boards.

thetonywarren 12-05-2021 05:14 PM

Re: TCL 75R615 has sound, no backlight
 
8 Attachment(s)
So, I got some help yesterday to take the TV off the wall and got the back off to check out the boards....I did find a capacitor that was blown out,looks to be C312 a ceramic disc capacitor, very small and challenging to read, but was able to with a magnifying glass.....it seems to be a 220pf 1kv, I ordered some new ones from digi-key. A couple of questions, I dont notice with this type of capacitor that there is any polarity that needs to be observed? I have replaced numerous electrolytic caps and they have obvious polarity markings on the circuit board as well as the cap itself. Please see the attached pictures of the part number of the panel as well as some pictures of the internal boards, please offer up any help if you can....Thanks.

dskall 12-05-2021 05:32 PM

Re: TCL 75R615 has sound, no backlight
 
No polarity on those. Does it measure as shorted?

thetonywarren 12-05-2021 05:37 PM

Re: TCL 75R615 has sound, no backlight
 
I just checked the component via continuity test and it is shorted.

lotas 12-05-2021 05:38 PM

Re: TCL 75R615 has sound, no backlight
 
This is a high-voltage ceramic capacitor, they have no polarity, you can safely install it as you like.

dskall 12-05-2021 05:41 PM

Re: TCL 75R615 has sound, no backlight
 
You can probably remove it and see if everything powers up. Just read my disclaimer first.

thetonywarren 12-05-2021 06:41 PM

Re: TCL 75R615 has sound, no backlight
 
I think I'll wait till I receive the new component, before I power it back up....

R_J 12-05-2021 08:59 PM

Re: TCL 75R615 has sound, no backlight
 
I would remove the disc cap and check it out of circuit, I would also check the mosfet QW301 & QW302. I usually replace these 1kv caps with a 2kv

thetonywarren 12-05-2021 09:18 PM

Re: TCL 75R615 has sound, no backlight
 
When you say take the disc cap out of circuit, I'm assuming you mean the one that blew up and not another one near it or a different one? I did desolder it took it out of circuit and it tested shorted out ....I'll also check the two MOSFETs like you suggested......crap, I already bought the 1kv version instead of the 2kv like you said.....

dskall 12-05-2021 09:41 PM

Re: TCL 75R615 has sound, no backlight
 
I'm surprised you had video.

R_J 12-05-2021 10:06 PM

Re: TCL 75R615 has sound, no backlight
 
The 1k will be fine if that is what you ordered.

R_J 12-05-2021 10:09 PM

Re: TCL 75R615 has sound, no backlight
 
Quote:

Originally Posted by dskall (Post 1089502)
I'm surprised you had video.

It seems to be the PFC circuit that has the shorted cap. The main board, t-con etc. likely operated and gave video but the led circuit needed the higher voltage and current to operate.

dskall 12-05-2021 10:27 PM

Re: TCL 75R615 has sound, no backlight
 
Thanks again for the info. I get on here mostly to learn. Do you know what happened to budm? Looks to be about a year since he posted.

thetonywarren 12-06-2021 08:41 AM

Re: TCL 75R615 has sound, no backlight
 
QW301 & QW302, as far as testing them....can they be tested in circuit, or do they need to be removed to be tested, I just want to make sure I do it the correct way.....im sure I can google a testing procedure, but I want to do it the quickest, most correct way....

Please let me know and thanks again for everyones help with this, it is much appreciated.....

lotas 12-06-2021 09:07 AM

Re: TCL 75R615 has sound, no backlight
 
You can check without soldering them, their legs should not be short-circuited with each other, this capacitor is parallel to the diodes.

thetonywarren 12-06-2021 01:01 PM

Re: TCL 75R615 has sound, no backlight
 
Ok, I'll test them later on this afternoon and post results on the mosfets....

thetonywarren 12-06-2021 06:15 PM

Re: TCL 75R615 has sound, no backlight
 
I tested both QW301 & QW302 in circuit and they are testing open across all legs.....I'm assuming per previous post that this means they are most likely good....

dskall 12-06-2021 07:21 PM

Re: TCL 75R615 has sound, no backlight
 
Well they shouldn't test open. Probably not testing them right, but they almost always test shorted if bad.

thetonywarren 12-07-2021 09:53 AM

Re: TCL 75R615 has sound, no backlight
 
Ok, does anyone have a good source for how I should be testing these particular mosfets? Ive viewed a few videos on youtube, but just looking for suggestions.....

Thanks!

dskall 12-07-2021 11:44 AM

Re: TCL 75R615 has sound, no backlight
 
Need the part numbers to know the gate, source and drain. Many videos on how to test.

R_J 12-07-2021 01:44 PM

Re: TCL 75R615 has sound, no backlight
 
Quote:

Originally Posted by thetonywarren (Post 1089908)
Ok, does anyone have a good source for how I should be testing these particular mosfets? Ive viewed a few videos on youtube, but just looking for suggestions.....

Thanks!

If they don't check shorted, they are very likely ok. For a proper test you need to remove them and that could just cause more problems.

thetonywarren 12-07-2021 08:07 PM

Re: TCL 75R615 has sound, no backlight
 
1 Attachment(s)
Ok, so I removed the heatsink that attaches to the two mosfets, I understand this is probably overkill but I wanted to be as throrough as possible. Please see the attached picture with both of the mosfets, I believe thy are MDF18N50, also see the attached link with the data sheet for reference....

https://datasheetspdf.com/pdf/830304...hip/MDF18N50/1

I will attempt to test both of these components per this video......

https://youtu.be/gloikp9t2dA

thetonywarren 12-08-2021 08:35 AM

Re: TCL 75R615 has sound, no backlight
 
I am still struggling in testing out these two mosfets, Im unable to re-create the testing results using 3 different multimeters I have with diode mode......Im not sure if Im doing something wrong or if there's something specific about these components that would prevent me from using a standard inexpensive multimeter in diode mode to test......any help is much appreciated......

Thanks in advance!!!

vinceroger69 12-08-2021 08:54 AM

Re: TCL 75R615 has sound, no backlight
 
Quote:

Originally Posted by thetonywarren (Post 1090120)
I am still struggling in testing out these two mosfets, Im unable to re-create the testing results using 3 different multimeters I have with diode mode......Im not sure if Im doing something wrong or if there's something specific about these components that would prevent me from using a standard inexpensive multimeter in diode mode to test......any help is much appreciated......

Thanks in advance!!!

I have one of these testers as i do find testing certain parts at times hard
https://www.ebay.co.uk/itm/143173138...YAAOSwPF9ci9rw

dskall 12-08-2021 10:26 AM

Re: TCL 75R615 has sound, no backlight
 
I maybe wrong here but I think your problem is that your gate to source is 10v to turn on mosfet. Your meter may not be able to do that.

thetonywarren 12-09-2021 08:30 AM

Re: TCL 75R615 has sound, no backlight
 
I kind of thought about that, even though I was not sure.....is it because my meter is powered with a 9v battery it doesnt have enough voltage to trigger the mosfet to turn on/off? I know that description is pretty crude/simple, just trying to understand the concepts.....If that's the case Im guessing i'd need a more powerful DMM or a bench type meter that plugs into the wall? Regardless, Im purchasing one of those cheap LCR tester meters on amazon to try and sort things out.....

thetonywarren 12-09-2021 10:06 PM

Re: TCL 75R615 has sound, no backlight
 
1 Attachment(s)
I replaced the cap as well as resoldering the heatsink and mosfets. I was too impatient to wait for the LCR meter to arrive. TV seems to power up normally!!! Great news. Thanks to all for the help and advice.

dskall 12-09-2021 11:58 PM

Re: TCL 75R615 has sound, no backlight
 
Thanks for feedback.


All times are GMT -6. The time now is 10:17 AM.

Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.