View Single Post
Old 03-05-2021, 11:18 PM   #18
momaka
master hoarder
 
momaka's Avatar
 
Join Date: May 2008
City & State: VA (NoVA)
My Country: U.S.A.
Line Voltage: 120 VAC, 60 Hz
I'm a: Hobbyist Tech
Posts: 10,371
Default Re: 1300W PSU - Help with replacement mosfet

Quote:
Originally Posted by sdinelli View Post
I do have both an ESR meter and a capacitance meter.
the two big caps ( i think these are what youre referring two)
are rated 470uf 400V CapXon
1st: 427uf .167 ESR
2nd: 422uf .177 ESR

both measure OL in resistence mode
That's good that both caps measure good. Otherwise, replacing these tends to add a fair amount to the cost of repairing these PSUs.

Since the caps aren't back, I went back and re-read the results you gave in post #5 and #10, along with the picture you posted with tested parts, to which I will be referring to on my comments below.

Quote:
Originally Posted by sdinelli View Post
I found a 10k smd off the gate measuring 4k and also a smd transistor labeled "2F" testing unlike the 2F on the other FET.
So referring to the abovementioned picture, I think that 4k resistance you're getting may be normal.
If you look at the left-most APFC TO-247 power MOSFETr spot (that you circled in red), notice there are holes/a spot on the PCB for another of the same MOSFET right directly behind it, but that MOSFET wasn't installed from the factory. Nonetheless, you can see that they did however install the small Gate pull-down resistor in spot R5b, along with the 47-Ohm Gate series resistor for that MOSFET. Therefore, when you measure the resistance across the 10k resistor in spot R5a, there could also be a parallel path through the other 47-Ohm resistor for the non-installed MOSFET and its 10k resistor (R5b). Thus, two parallel 10k resistors will read about 5 kOhms. The 4k resistance you got is lower... but maybe double-check that. Or maybe there are other shorted parts still.

I'm also not sure why they would install the Gate-driving transistors for the MOSFET that wasn't installed... but bad comes to worse, those should still technically be good... so maybe you can use them to replace the ones for the blown FET without having to buy new parts?
.
.
Next, look all the way to the right at the blown power resistor you circled in red - this one is likely the current sense resistor for the main switching PS. If this is bad, there's a good chance one or both power transistors next to it (circled in yellow) could also be bad. As such, you may have to remove them to check them (or at least one of them), along with their Gate driver circuits. On that note, I'm not able to determine yet if this PSU uses double-forward or resonant LLC topology, based on the pictures you provided. Thus, I can't really comment how the Gate drive components for those MOSFETs you circled in yellow should measure.

Last edited by momaka; 03-05-2021 at 11:22 PM..
momaka is offline   Reply With Quote