View Single Post
Old 06-09-2021, 04:30 PM   #12
eccerr0r
Solder Sloth
 
eccerr0r's Avatar
 
Join Date: Nov 2012
City & State: CO
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist Tech
Posts: 7,084
Default Re: Fixing a laboratory waterbath

So ultimately the problem is a trace got vaporized and you added a link.... and apparently it worked for a while but then stopped.

So it seems like either the solder link is bad or the transformer's pins or internal connection to its pins are not working correctly. Ideally it's welded to the posts internally but sometimes they're soldered and if you dwell on the pin too long you melt the internal pin and all hell breaks loose... Or if you overload the transformer...

Would have to say these transformers are hard to come by these days, specifically line frequency to multiple output.

I also have to mention that the transformer/tracks may have been underspecced Looks like the manufacturer may have tried to make it easy to switch between 120/240V but did not compensate for the fact that it takes 2x more current at 120V...

BTW you may end up having to use multiple transformers... or if you're really crazy you might be able to get a step up transformer and rewire the transformer to 220V and power it that way ... LOL

Last edited by eccerr0r; 06-09-2021 at 04:36 PM..
eccerr0r is offline   Reply With Quote