View Single Post
Old 02-08-2020, 01:15 PM   #1
Send Doge Memes
shovenose's Avatar
Join Date: Aug 2010
City & State: Fairfax, California
My Country: USA
I'm a: Forum Junkie
Posts: 6,189
Default Marvell Gigabit controller stuck at 100Mbps

My NAS is a Windows 10 1909 64-bit PC running on an EVGA Z68 FTW motherboard which uses a Marvell 88E8057 network controller.

The problem is that the network connection is stuck at 100Mbps. That really sucks when I'm trying to move large files around.

I tried a few different network cables, I tried moving it from my Asus router to my Netgear switch (both of which are obviously gigabit).

Driver version is which was automatically installed by Windows. EVGA's website lists an older version than that. Marvell's website lists but when I try to install it, it says "a newer version is already installed"

Not sure what the next step is besides putting in a PCI-E NIC which I really don't feel like doing.
Attached Images
File Type: png Untitled.png (80.8 KB, 40 views)

Last edited by shovenose; 02-08-2020 at 01:19 PM..
shovenose is offline   Reply With Quote