View Single Post
Old 11-03-2021, 03:10 PM   #1
grimacelord
Senior Member
 
Join Date: Jan 2017
City & State: Atlanta, GA
My Country: USA
I'm a: Knowledge Seeker
Posts: 145
Default Samsung UN50MU6070FXZA - HDMI Ports Not Working

Hello. Samsung UN50MU6070FXZA here with both HDMI ports non-working. I have already verified multiple sources and multiple cables to ensure it isn't something simple like that as well as resets and software updates.

I took the mainboard out and gave it a look. Nothing looks bad or burned. All of the HDMI pins are nice, none are broken at their pads either.

Following the traces, it looks like both HDMI ports trace back to the main CPU which does seem to get hotter than I think it should despite it's (rather poor) heatsink.

Since the HDMI controller appears to be integrated within the CPU, is the CPU the culprit? The TV turns on just fine and everything seems to work ok except for these two HDMI ports.

Just going off of past experience, it almost SEEMS like the CPU got too hot after the life of the TV due to the shoddy heatsink installed by Samsung. One or more of the BGA balls under the chip is damaged from the heating/cooling over and over and while it turns on ok, no HDMI. Does this sound like a reasonable theory?

If I am right, wouldn't a reflow/reball potentially fix this issue? I don't want to reflow/reball it if I don't have to because like I said, the TV still works fine otherwise.

I'm attaching some pics. Let me know what you guys think. Thanks.
Attached Images
File Type: jpg PXL_20211103_170131429.jpg (1,022.1 KB, 15 views)
File Type: jpg PXL_20211103_170143222.jpg (706.7 KB, 8 views)
File Type: jpg PXL_20211103_170157779.jpg (932.9 KB, 14 views)
grimacelord is offline   Reply With Quote