View Single Post
Old 02-17-2021, 05:24 PM   #1
liquidzorch
Member
 
Join Date: Oct 2016
City & State: coahuila
My Country: mexico
I'm a: Knowledge Seeker
Posts: 52
Default DSLR canon sl2 flash error 50

Hello. I repaired a canon sl2 for personal use, it had a bad sd card slot, bad battery connector, plus a little bit of water residue on the motherboard. The water damage seems to not have caused any damage, just salt deposits that have been cleaned. After repairing everything works except for the flash.

When shooting with the flash turned on, i get a "wait" message once, then on the second try I get an error: e50. I have disassembled the front to get a look at the flash board, and everything seems good, the flash board also controls the shutter, which works, so it does have communication with the motherboard.

I have probed the transistor that switches the transformer (that goes to the flash capacitor), it has battery voltage, but never gets switched. No voltage change was detected on the gate pin with an oscilloscope. It seems this gate pin is connected directly to the motherboard via a flex, I can trace it al the way to the motherboard connector, then I cant seem to find where it goes.

Does anyone know what I should check? I don't have pictures, I have closed the camera and I am using it daily, so I don't want to open it again until I have some new ideas. But I canīt find schematics.

What has to be working for the flash capacitor to charge up? Does it do any check before so? Maybe check the flash bulb somehow. Sorry, I have absolutely no experience with flashes.
liquidzorch is offline   Reply With Quote