Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-31-2020, 07:47 PM   #1
bwilliams60
Member
 
Join Date: Aug 2014
City & State: London, Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 99
Default LG 42LE7500 TV Backlighting but no Picture

Good Evening All. I have a 42" LG TV that was given to me and my background is more automotive electronics so was hoping for some direction on this. I can get around the TV okay, just need pointing in the right direction. This TV starts up okay and backlighting comes on with no problem but there is absolutely no picture. I have ran an infrared monitor over the power supply and most areas that I think should get hot, are, but that is obviously no measure of anything so where should I start with this one?
It has two boards in it. Mainboard and Power Supply I am assuming. I don't have any pictures yet but if you need them, I can upload some later on.
Thank you in advance.
bwilliams60 is offline   Reply With Quote
Old 01-31-2020, 07:58 PM   #2
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 5,892
Default Re: LG 42LE7500 TV Backlighting but no Picture

Yep, throw up some good straight on pictures of all the boards and one of the whole back and how they are connected, try test number 3 below.
__________________
1) https://www.youtube.com/watch?v=4F2J1Dkf4Is
HIGH VOLTAGE HAZARD demonstration. Video by Electronic Doberman.
Always happy to help decent people save stuff from the landfill and I'm always open to a good stock tip, Thanks.
nomoresonys is offline   Reply With Quote
Old 01-31-2020, 08:19 PM   #3
bwilliams60
Member
 
Join Date: Aug 2014
City & State: London, Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 99
Default Re: LG 42LE7500 TV Backlighting but no Picture

Okay here are the voltages I got with Power Off and then Power On
ON 0.00 VDC 3.25 VDC 20V 0.00 VDC 21.4 VDC
20V 0.00 VDC 21.40 VDC 20V 0.00 VDC 21.4 VDC
GND 0.00 VDC 0.00 VDC GND 0 0
GND 0.00 VDC 0.00 VDC GND 0 0
3.5V 3.48 VDC 3.40 VDC 3.5V 3.3 3.3
3.5V 3.48 VDC 3.40 VDC 3.5V 3.3 3.3
GND 0.00 VDC 0.00 VDC GND 0 0
GND 0.00 VDC 0.00 VDC V-SYNC 0 0
12V 0.00 VDC 12.28 VDC DRV-ON 0 2.9
12V 0.00 VDC 12.28 VDC SCLK 0 0
12V 0.00 VDC 12.28 VDC PWR DIM 0 3.2
SIN 0.00 VDC 0.02 VDC Error Out 0 0

Pictures to follow momentarily

Last edited by bwilliams60; 01-31-2020 at 09:00 PM..
bwilliams60 is offline   Reply With Quote
Old 01-31-2020, 08:23 PM   #4
bwilliams60
Member
 
Join Date: Aug 2014
City & State: London, Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 99
Default Re: LG 42LE7500 TV Backlighting but no Picture

Here are my pics. I suspect that 20V circuit may be a problem?
Attached Images
File Type: jpg 20200131_210205.jpg (901.5 KB, 10 views)
File Type: jpg 20200131_210211.jpg (978.9 KB, 6 views)
File Type: jpg 20200131_210250.jpg (902.5 KB, 6 views)
File Type: jpg 20200131_210310.jpg (1,022.0 KB, 6 views)
File Type: jpg 20200131_210318.jpg (1.01 MB, 6 views)
File Type: jpg 20200131_210329.jpg (704.7 KB, 5 views)
File Type: jpg 20200131_210218.jpg (986.5 KB, 6 views)
bwilliams60 is offline   Reply With Quote
Old 02-02-2020, 04:42 AM   #5
tvtimmy
Badcaps Veteran
 
tvtimmy's Avatar
 
Join Date: Mar 2015
City & State: milwaukee,wi
My Country: usa
Line Voltage: 120VAC/60HZ
I'm a: Knowledge Seeker
Posts: 970
Default Re: LG 42LE7500 TV Backlighting but no Picture

The cpu chip is in need of a re-balling, or a quick reflow with a heat gun on low for about 45 seconds. Remove the big black heatsink, then heat it evenly.
tvtimmy is offline   Reply With Quote
Old 02-02-2020, 01:37 PM   #6
bwilliams60
Member
 
Join Date: Aug 2014
City & State: London, Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 99
Default Re: LG 42LE7500 TV Backlighting but no Picture

Thank you @tvtimmy for your response. I have seen where people have heated their mainboards in an oven at 380 for ten minutes. What you are saying is to just heat the cpu? Is that the only part that is losing connection? I can do that with my hot air station. Any recommended temperature? I generally run my station at 225 for most things. Thoughts?
bwilliams60 is offline   Reply With Quote
Old 02-02-2020, 04:13 PM   #7
tvtimmy
Badcaps Veteran
 
tvtimmy's Avatar
 
Join Date: Mar 2015
City & State: milwaukee,wi
My Country: usa
Line Voltage: 120VAC/60HZ
I'm a: Knowledge Seeker
Posts: 970
Default Re: LG 42LE7500 TV Backlighting but no Picture

Just heat up the chip under the black heatsink. A hot air station will work very well, only heat the chip . I put a towel under the board to prevent the surface mounted parts from falling off. Set the temp just over what it takes to melt leaded solder. Let it cool and try it out.
tvtimmy is offline   Reply With Quote
Old 02-19-2020, 11:45 PM   #8
arbitarytwist
New Member
 
Join Date: Nov 2016
City & State: BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 13
Default Re: LG 42LE7500 TV Backlighting but no Picture

Did this fix your issue?
arbitarytwist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:27 AM.
Did you find this forum helpful?