Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 04-03-2022, 12:34 PM   #1
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Blinking stby led on a TD systems TV with 17IPS11 PS

Hi There!
I have a TV set (model TD Systems K32DLV1H) which doesn't power up.
During power off, the stby red led is on, as it should, then I press power button on remote and the led starts blinking, endlessly.

Sounds to me like a PS problem. TV is kinda alive as it stays in Stand-by, recognizes power up button from remote, etc, but can't really power up.

Internal PS is a 17IPS11. First inspection shows no damaged components, no swollen caps, and multimeter shows all diodes are good. Also there's a dual diode transistor shaped component on a heatsink that measures ok, and also a (probably) mosfet on another heatsink measuring no shorts on any pin

Being lead by other forums it makes me believe it could have to deal wih the backlight. Now the question is, how can I determine, without removing the LCD panel, if the issue is with the LED strips themselves, or the LED voltage generator in the PS? Or maybe you guys can provide any other hint on what to check?

Any help would be greatly appreciated!!
Thanks
edugimeno is offline   Reply With Quote
Old 04-03-2022, 12:48 PM   #2
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,806
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Need pictures of boards and connectors. Voltages from power board to main and led in standby and when powered up. You may be able to unplug t-con and power up might bring up backlights. You can tap screen to see if backlights are working. Also use flashlight to see if there is an image on screen.
__________________
I assume no responsibility for any stupid suggestions I might post.

Last edited by dskall; 04-03-2022 at 12:53 PM..
dskall is offline   Reply With Quote
Old 04-03-2022, 02:47 PM   #3
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Hi.

Turn-on the tv and Check led voltage. If voltage around 70V-90V replace led bars.
__________________
GenÁ Elektronik ve Bilgisayar
arizanotlari is offline   Reply With Quote
Old 04-03-2022, 02:52 PM   #4
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by dskall View Post
Need pictures of boards and connectors. Voltages from power board to main and led in standby and when powered up. You may be able to unplug t-con and power up might bring up backlights. You can tap screen to see if backlights are working. Also use flashlight to see if there is an image on screen.
Ok I will check this tomorrow as right now I have the PSU board out for further tests
Thanks!
edugimeno is offline   Reply With Quote
Old 04-03-2022, 02:52 PM   #5
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by arizanotlari View Post
Hi.

Turn-on the tv and Check led voltage. If voltage around 70V-90V replace led bars.
I did test this before I took the PSU board out, it measured 19v. Short in the LEDS?
edugimeno is offline   Reply With Quote
Old 04-03-2022, 03:48 PM   #6
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

No. unplug led cable from psu. connect probs to led socket. turn-on tv and measure the voltage at the first moment.
arizanotlari is offline   Reply With Quote
Old 04-04-2022, 11:02 AM   #7
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Ok I got some measurements
All this is assuming that the verson on my PS is this one:
https://elektrotanya.com/vestel_17ip.../download.html
(mine is using the 2x6 connector enclosed in a box)
Before power up measurements:
(1) "PIN1": 0v
(3) "STDBY": 2,5v
(5) "BLON_OFF": 0v
(7) "PWM_DIM": 0v
(9) "STBY_ON": pulsing around 250mV
(11) "+12v": +12v
(13) "+12v": +12v

Then when I power it on:
(1) "PIN1": 0v
(3) "STDBY": 0v
(5) "BLON_OFF": 0v
(7) "PWM_DIM": 3,3v
(9) "STBY_ON": pulsing around 130mV
(11) "+12v": +12v
(13) "+12v": +12v

Now about LED power. It doesn't matter if I have the wire plugged to the leds or not. 0v when stdby, that rises to 20v when triting to power on. No higher pulses than 20v.

Someone asked to try with T-con removed, this set doesn't have a T-con board. But I tried while the ribbon from MAIN to LCD was unplugged with no changes.

Thanks everyone!
edugimeno is offline   Reply With Quote
Old 04-04-2022, 11:32 AM   #8
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,806
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Looks like maybe a mainboard problem.
Ok looking at pin 9 should have 5v I think. So maybe power supply. I am not good with schematics. Maybe someone else ccan jump in with schematic knowledge.

Last edited by dskall; 04-04-2022 at 12:15 PM..
dskall is offline   Reply With Quote
Old 04-04-2022, 11:37 AM   #9
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Mainboard? Why do you think that? I still believe it's the PS
edugimeno is offline   Reply With Quote
Old 04-04-2022, 12:02 PM   #10
Diah
Badcaps Veteran
 
Join Date: Feb 2013
City & State: SA
My Country: Germany
I'm a: Professional Tech
Posts: 3,547
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by edugimeno View Post
Ok I got some measurements
All this is assuming that the verson on my PS is this one:Thanks everyone!
yours measurements could be error.. can you disconnect the MB from the PCB totaly. just plug in wall and give yours new measurements on the socket which it goes to MB !!
Diah is offline   Reply With Quote
Old 04-04-2022, 01:45 PM   #11
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Pin 3 and 5 not good. I misunderstood your problem at first. If the standby led is blinking continuously, there is a problem with the motherboard.
arizanotlari is offline   Reply With Quote
Old 04-04-2022, 01:48 PM   #12
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

The stdby led blinks only when I try to power it on, but it stays lit when powered off (as it should). Once I try to power it on, it blinks, and then there's no way to power it off again (getting it to solid lig again) unless I unplug it from mains and plug it back in

My measurements varied just a little when I tried with MB unplugged. I still believe it's the PS, as I don't even get +5v on STBY_5V when unplugged from MAIN board
edugimeno is offline   Reply With Quote
Old 04-04-2022, 01:50 PM   #13
edugimeno
Senior Member
 
Join Date: May 2017
City & State: Spain
My Country: Spain
I'm a: Knowledge Seeker
Posts: 149
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by edugimeno View Post
(9) "STBY_ON": pulsing around 250mV
Sorry PIN 9 is labeled "+5V STBY" on the schematic. I don't get this voltage
edugimeno is offline   Reply With Quote
Old 04-04-2022, 01:59 PM   #14
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Pin 9 is not connected, forget it.

What is mainboard name?
arizanotlari is offline   Reply With Quote
Old 04-04-2022, 02:03 PM   #15
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

I give you a tip: if you connect 12V 1A adapter to pin 1 (ground) and pin 13 (plus) motherboard working without psu. You can test mb this way.
arizanotlari is offline   Reply With Quote
Old 04-04-2022, 02:18 PM   #16
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,187
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

maybe check the electrolytic caps closest to the connector and check all the diodes, does seem like your standby voltage is looking funky.
nomoresonys is offline   Reply With Quote
Old 04-04-2022, 02:32 PM   #17
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,187
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

pictures would help.
nomoresonys is offline   Reply With Quote
Old 04-04-2022, 02:35 PM   #18
Diah
Badcaps Veteran
 
Join Date: Feb 2013
City & State: SA
My Country: Germany
I'm a: Professional Tech
Posts: 3,547
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by edugimeno View Post
My measurements varied just a little when I tried with MB unplugged. I still believe it's the PS, as I don't even get +5v on STBY_5V when unplugged from MAIN board
MANNN... how it come your measurements varied just a little when the MB unplugged ???? how it come you have 12V on the socket and the MB didn't send any power on signal.... can you explain...???? there are no power boards work from alone to provide operation VCC 12V with out power on... LOL
Diah is offline   Reply With Quote
Old 04-04-2022, 03:10 PM   #19
arizanotlari
Senior Member
 
Join Date: Nov 2014
City & State: Diyarbakir
My Country: Turkiye
Line Voltage: 220VAC 50Hz
I'm a: Professional Tech
Posts: 142
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by Diah View Post
MANNN... how it come your measurements varied just a little when the MB unplugged ???? how it come you have 12V on the socket and the MB didn't send any power on signal.... can you explain...???? there are no power boards work from alone to provide operation VCC 12V with out power on... LOL
Some Vestel boards do that. 12V always on. Other 3 signal send from mb to psu.
arizanotlari is offline   Reply With Quote
Old 04-04-2022, 03:44 PM   #20
Diah
Badcaps Veteran
 
Join Date: Feb 2013
City & State: SA
My Country: Germany
I'm a: Professional Tech
Posts: 3,547
Default Re: Blinking stby led on a TD systems TV with 17IPS11 PS

Quote:
Originally Posted by arizanotlari View Post
Some Vestel boards do that. 12V always on. Other 3 signal send from mb to psu.
so you mean at this PCB the 12V always active... then the MB should have stepdown circuit to let the SPI run 3.3V to send signal back to PCB via the OPTO to run PFC hight >400V to provide the T to work and provide AC -- to DC 24V for LEDS BL. only this i can imagine it. so funny design... would better to them to let it work with external transformer...

Last edited by Diah; 04-04-2022 at 03:48 PM..
Diah is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:51 AM.
Did you find this forum helpful?