Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 07-01-2022, 04:54 PM   #1
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Sony XBR-65X850E power supply board diode replacement

I have a Sony XBR-65X850E that when plugged in buzzes for a few seconds about 5-7 times but the screen never comes on. It looks like one of the four diodes on the main power supply board are bad. Iíd like to replace all four at the same time. The diodes that are bad are the D750, D751, D752 and D753. The S750 looks discolored and fails the diode test on the board. It hasnít been removed from the board yet for testing.

Are all four of these the same diode? I saw a video that called the discolored one a Schottky 5150 diode. How can I make sure to get the right diodes for these?

Thanks!
Attached Images
File Type: jpeg 941887A8-CB78-440A-93E0-BD556193E540.jpeg (111.2 KB, 25 views)
Tnmg is offline   Reply With Quote
Old 07-01-2022, 05:32 PM   #2
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,809
Default Re: Sony XBR-65X850E power supply board diode replacement

What are the numbers on them? All 5150?
__________________
I assume no responsibility for any stupid suggestions I might post.
dskall is offline   Reply With Quote
Old 07-01-2022, 06:32 PM   #3
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,191
Default Re: Sony XBR-65X850E power supply board diode replacement

not seeing an S750, where is it? if you mean D750, take it out of circuit and recheck it, it's the only one that failed the test?

Last edited by nomoresonys; 07-01-2022 at 06:34 PM..
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 06:32 PM   #4
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,161
Default Re: Sony XBR-65X850E power supply board diode replacement

All four diodes are the same, they are setup as a bridge.

I believe the S750 is a typ0, should be D750
R_J is offline   Reply With Quote
Old 07-01-2022, 06:45 PM   #5
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

Quote:
Originally Posted by dskall View Post
What are the numbers on them? All 5150?
Thatís what they look like. I havenít taken them out yet.
Tnmg is offline   Reply With Quote
Old 07-01-2022, 06:46 PM   #6
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

Quote:
Originally Posted by R_J View Post
All four diodes are the same, they are setup as a bridge.

I believe the S750 is a typ0, should be D750
That’s correct. Typo indeed. The discolored one is D750.

So all four should be the same? Any way to confirm they are Schottky 5150s? I saw a multipack ld them on Amazon but don’t know how to verify they’re the right ones.

Last edited by Tnmg; 07-01-2022 at 06:48 PM..
Tnmg is offline   Reply With Quote
Old 07-01-2022, 06:47 PM   #7
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

Quote:
Originally Posted by nomoresonys View Post
not seeing an S750, where is it? if you mean D750, take it out of circuit and recheck it, it's the only one that failed the test?
Thatís correct, itís D750. I havenít taken them out, just checked them on the board. Figured Iíd just change them all once I got the new ones.
Tnmg is offline   Reply With Quote
Old 07-01-2022, 06:54 PM   #8
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,191
Default Re: Sony XBR-65X850E power supply board diode replacement

just order them by the numbers on the diode, can't go wrong that way.
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 06:59 PM   #9
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,191
Default Re: Sony XBR-65X850E power supply board diode replacement

best way to confirm is take out of circuit and retest, when you put them back in just make sure the stripe is in the right direction. Usually adding a little new solder to the joints makes the component come out much easier.
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 07:05 PM   #10
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

Quote:
Originally Posted by nomoresonys View Post
just order them by the numbers on the diode, can't go wrong that way.
Will do. Thanks!
Tnmg is offline   Reply With Quote
Old 07-09-2022, 12:48 PM   #11
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

Replaced the diode that appeared to have failed and power supply works now. Have a new problem but Iíll make a separate post for that. Thanks for the help.
Tnmg is offline   Reply With Quote
Old 07-18-2022, 01:08 PM   #12
Tnmg
Member
 
Join Date: Dec 2015
City & State: Pendleton SC
My Country: United States
I'm a: Knowledge Seeker
Posts: 27
Default Re: Sony XBR-65X850E power supply board diode replacement

So, the power supply board is good. The TV boots up and a solid blue line shows up on the right side of the screen centered on a 6 inch black vertical bar. I attached a pic to see. I donít have the remote from the tv so I canít go any farther with the tv setup. Everything up this point seems to be working. Volume, horizontal lines are good. Rest of the screen is good vertically.

The blue line brightens and dims in intensity but the black vertical bar never goes away.

Any help is greatly appreciated.
Attached Images
File Type: jpeg 7BA98E8A-E116-4761-A694-FDE900EF3BA1.jpeg (43.4 KB, 8 views)
Tnmg is offline   Reply With Quote
Old 07-18-2022, 08:01 PM   #13
neilc6
Badcaps Veteran
 
Join Date: Nov 2015
City & State: BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,379
Default Re: Sony XBR-65X850E power supply board diode replacement

Static vertical lines are damaged panels. Google Sony tcon training manual.
neilc6 is online now   Reply With Quote
Old 07-18-2022, 08:38 PM   #14
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,191
Default Re: Sony XBR-65X850E power supply board diode replacement

maybe check the little capacitors on the panel driver board for shorts or very low ohms, right there in that area where you have the black stripe, it is a big bar, could try the tape cut off method, might not work but won't hurt to try, maybe check diodes/diode packs and other components on those boards also.
nomoresonys is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:13 AM.
Did you find this forum helpful?