Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-27-2021, 10:19 AM   #1
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Hitachi 55" TV dead after 18 months (Vestel 17MB100)

I couldn't find any other thread that matches my TV problem but have been told it is a common fault. The fault is a flashing LED as if it is in upgrade mode that happens after a few seconds and stays forever. I can't remember all the tricks that have been tried like holding the select button when powering on but nothing worked. The shop sent me a flash drive to plug in a USB port but that did nothing either and they said it was dead which is disgusting for a piece of solid state electronics. I took the back off eventually after removing 34 screws to check for blown caps but everything looks new as you would expect for only 18 months use. The board is a Vestel 17MB100 and I think it died when it was doing an upgrade because the TV screen came up then it checked for an upgrade turned off the screen and stayed with the flashing LED for over half an hour.
I have some questions to start.
1) Is the flash drive meant to be bootable (mine isn't) or just a bunch of files?
2) Can a serial lead be plugged in to see a boot up log like some other TVs?
3) Any ideas on how to fix it or find out what is wrong?
Ruptor is offline   Reply With Quote
Old 09-27-2021, 01:17 PM   #2
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months

Your tv its probably a vestel. You need to flash the correct firmware for your tv using a usb stick. You just throw a bunch of files into the usb stick, a working remote control and you are good to go. A blinking led light dosent necessarily mean that its a bad firmware, but a firmware update solves the problem 90% of the time.
ducky29 is offline   Reply With Quote
Old 09-27-2021, 03:53 PM   #3
petehall347
Badcaps Veteran
 
Join Date: Jan 2015
City & State: worcester
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 3,280
Default Re: Hitachi 55" TV dead after 18 months

normally first format drive as fat 32 . but that should have been done .
petehall347 is online now   Reply With Quote
Old 09-27-2021, 04:29 PM   #4
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months

I have a USB from Hitachi with the appropriate files that reads on a computer. When they first sent me the USB I tried it in both USB ports and held the Button on the back of the TV but it didn't change the LED blinking.
It is still the same now but with the back of the TV off I can hear a faint hiss from the power supply that seems to tick as if the switching part of the PSU is on is this normal? I would have thought the standby or even flashing LED wouldn't start any of the heavy supply running or is the blinking LED state a turned on PSU state?

Last edited by Ruptor; 09-27-2021 at 04:32 PM.. Reason: typo
Ruptor is offline   Reply With Quote
Old 09-28-2021, 12:16 AM   #5
yokoono
Badcaps Veteran
 
Join Date: Apr 2010
Posts: 322
Default Re: Hitachi 55" TV dead after 18 months

If it is Vestel:
1. format a stick (preferably 4-8 Gb) with FAT32
2. unzip and put the files directly on the stick
3. Unplug the TV
4. insert the stick in the tv. Preferably usb next to CI card
5. press and hold the OK key on the remote control
6. Plug in the TV.
7. The left LED on the TV will flash slowly at first and, after a few seconds, faster
8. release the ok key
9. wait for it to finish. It can take 3-10 minutes
yokoono is offline   Reply With Quote
Old 09-28-2021, 06:04 AM   #6
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

I tried that with the remote OK instead of the button on the back of the TV but no change. The flash drive sent to me by Hitachi with appropriate files looks like the picture. Any more suggestions?
Attached Images
File Type: png HitachiPen.png (16.1 KB, 28 views)
Ruptor is offline   Reply With Quote
Old 09-28-2021, 06:23 AM   #7
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Try a smaller capacity usb drive (2.0). Format the usb stick and copy paste 5 files.
ducky29 is offline   Reply With Quote
Old 09-28-2021, 06:49 AM   #8
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by ducky29 View Post
Try a smaller capacity usb drive (2.0). Format the usb stick and copy paste 5 files.
I can try and fudge a smaller capacity SD card in a USB adapter but why would Hitachi send me a USB stick that wouldn't work because it is too big for their TV?
Ruptor is offline   Reply With Quote
Old 09-28-2021, 07:20 AM   #9
yokoono
Badcaps Veteran
 
Join Date: Apr 2010
Posts: 322
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Hold down the OK key for a longer time. It can take up to 1 minute.
yokoono is offline   Reply With Quote
Old 09-28-2021, 07:51 AM   #10
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by Ruptor View Post
I can try and fudge a smaller capacity SD card in a USB adapter but why would Hitachi send me a USB stick that wouldn't work because it is too big for their TV?
My bad, I thought Hitachi sent you the files and not the usb stick. Try holding ok for a bit longer or keep pressing ok button repeatedly.

If it dosen't take firmware then it might be a hardware problem or a problem that can't be solved just with a usb stick.
ducky29 is offline   Reply With Quote
Old 09-28-2021, 09:15 AM   #11
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by ducky29 View Post
I thought Hitachi sent you the files and not the usb stick. Try holding ok for a bit longer or keep pressing ok button repeatedly.
I held the OK button & the button on the back of the TV for 2.5 minutes but no change. I just found a 2 GB SD card I can use but won't bother given your last post. Pressing the button lots of time made no difference either.
What about the faint hissing and ticking coming from the PSU does that point to any thing? In this LED flashing mode should the PSU be fully on?
Ruptor is offline   Reply With Quote
Old 09-28-2021, 01:45 PM   #12
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Probably a mainboard (firmware) related issue that can't be solved using the usb so you might need further help from a technician. You might need to reprogram or replace the emmc, but you never know, its not that easy diagnosing through a forum.So I don't know about faint hissing but I think its constantly trying to start up the mainboard.Your best bet is to get it fixing under warranty but I guess your warranty is voided becouse you already opened the back, but you can give hitachi a call and ask them.
Your tv model maybe 55HK6T64U or 55HGW69; so I checked for a mainboard replacement but I might need more info to get you the correct replacement, otherwise get a board and then update the firmware sent from hitachi.
ducky29 is offline   Reply With Quote
Old 09-28-2021, 03:28 PM   #13
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by ducky29 View Post
Your best bet is to get it fixing under warranty but I guess your warranty is voided becouse you already opened the back, but you can give hitachi a call and ask them.
Our TV is 55HK6T64U and had a 1 year warranty that is why they said buy a new one when the USB stick didn't fix it. Can you point me to a circuit diagram of the PSU that I can replace parts on if it is faulty and any information on the Vestel CPU board? I found a manual that appears to cover a lot of boards but it jumps from 95 to 130 with no mention of my 100 board that seems to be an oddball.
Ruptor is offline   Reply With Quote
Old 09-28-2021, 04:07 PM   #14
lotas
Badcaps Veteran
 
Join Date: Jan 2016
City & State: Sochi
My Country: russia
I'm a: Knowledge Seeker
Posts: 870
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Service manual hitachi 55hk6t64u
Attached Files
File Type: pdf hitachi_55hk6t64u_chassis_17mb100-r1_17ips20-r9_sm.pdf (12.35 MB, 26 views)
lotas is offline   Reply With Quote
Old 09-28-2021, 05:30 PM   #15
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by lotas View Post
Service manual hitachi 55hk6t64u
Thanks a lot I have a chance of finding where the fault is now. I will report my findings and solution if one is available.
Ruptor is offline   Reply With Quote
Old 09-29-2021, 12:21 AM   #16
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

It must be a faulty mainboard not a faulty PSU.
ducky29 is offline   Reply With Quote
Old 10-05-2021, 07:43 AM   #17
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by ducky29 View Post
get a board and then update the firmware sent from hitachi.
If a board is 17MB100 and it looks the same as mine can I use my Hitachi USB and change it for my TV?
My Main Board 23348885
New Main Board 23306084
Ruptor is offline   Reply With Quote
Old 10-05-2021, 07:59 AM   #18
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 333
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by Ruptor View Post
If a board is 17MB100 and it looks the same as mine can I use my Hitachi USB and change it for my TV?
My Main Board 23348885
New Main Board 23306084
They look the same but the screen is different. The image might be ok or it might be flipped, solarized.You never gonna know until you try.

Probably even the remote might be different. You might need to flash the firmware from Hitachi again but you need a toshiba remote control to flash it.

There are few listings for your board on ebay...
ducky29 is offline   Reply With Quote
Old 10-05-2021, 08:34 AM   #19
Spitz
Member
 
Join Date: Oct 2010
Posts: 95
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by Ruptor View Post
Our TV is 55HK6T64U and had a 1 year warranty that is why they said buy a new one when the USB stick didn't fix it. Can you point me to a circuit diagram of the PSU that I can replace parts on if it is faulty and any information on the Vestel CPU board? I found a manual that appears to cover a lot of boards but it jumps from 95 to 130 with no mention of my 100 board that seems to be an oddball.
Did you buy it using a credit card? Some credit cards will double the factory warranty if purchased through them.
Spitz is offline   Reply With Quote
Old 10-05-2021, 11:32 AM   #20
Ruptor
Member
 
Join Date: Sep 2021
City & State: London
My Country: GB
I'm a: Knowledge Seeker
Posts: 32
Default Re: Hitachi 55" TV dead after 18 months (Vestel 17MB100)

Quote:
Originally Posted by Spitz View Post
Did you buy it using a credit card? Some credit cards will double the factory warranty if purchased through them.
Yes maybe but it failed over 9 months ago and I was so disgusted with it I put it out of sight to stop me from smashing it up.
Ruptor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:42 PM.
Did you find this forum helpful?