Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-20-2011, 02:37 PM   #1
CAnderson
New Member
 
Join Date: Nov 2011
Posts: 2
Default 50pc3d LG tv replaced caps and still nothing

I know this has been gone over before, but I wanted to start a fresh one for my scenario.

I acquired a 50pc3d LG tv that had the three flashing greens then back to red scenario so I replaced the 9 bulging caps on the power board. I still have the three flashing greens and back to red!!
With the back cover off I plugged the power cord in and I can hear it get power and click, but there are no led's lighting up anywhere like like I've seen on others when you first power up.
Any ideas, solutions?
CAnderson is offline   Reply With Quote
Old 11-20-2011, 09:13 PM   #2
Dgtech
E. Technician
 
Dgtech's Avatar
 
Join Date: Apr 2009
City & State: Pittsburgh
My Country: Steeler
Line Voltage: 120 VAC 60Hz
I'm a: Professional Tech
Posts: 1,403
Default Re: 50pc3d LG tv replaced caps and still nothing

Post pictures
__________________
The strong-minded rise to the challenge of their goals,the weak-minded BECOME HATERS

Dgtech is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 07:36 AM.
Did you find this forum helpful?