Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Desktop Motherboards, Graphics Cards, and PC Peripherals
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-17-2021, 07:11 PM   #1
gersrt
New Member
 
Join Date: Jan 2021
City & State: Dublin 15
My Country: Ireland
I'm a: Knowledge Seeker
Posts: 19
Default iMac 2014 27inch. No display or output. All 4 diagnostic leds are lit green

Hi. I'm trying to figure out what the issue is with my imac 2014 27 retina. When I turn on the screen goes light black and no chime. There is no output from the back port to hdmi.

I thought at first it might be a gpu issue. But all four diagnostic leds are lit up inside. Was sure if there was an issue with the gpu one of them would be off.

Any help please?
gersrt is offline   Reply With Quote
Old 05-18-2021, 12:39 AM   #2
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 3,468
Default Re: iMac 2014 27inch. No display or output. All 4 diagnostic leds are lit green

1) post a picture of your screen after the power up

2) try a PRAM reset
mon2 is offline   Reply With Quote
Old 06-02-2021, 07:04 AM   #3
pascable
Member
 
Join Date: Feb 2018
City & State: Reims
My Country: France
I'm a: Knowledge Seeker
Posts: 21
Default Re: iMac 2014 27inch. No display or output. All 4 diagnostic leds are lit green

I rebelled one who had the same symptom.
I ask the customer if the four LEDs were on or not and I give you the info, if I have it, asap.
In my opinion a reballing will be necessary.
My client replied that he had all four LEDs on despite the GPU being rebellious.
Do you need the temperature curves to rebound?
pascable is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:54 PM.
Did you find this forum helpful?