Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Audio Equipment
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-30-2020, 08:00 AM   #1
macjedimatt
Member
 
Join Date: May 2012
City & State: Dracut, MA
My Country: USA
I'm a: Knowledge Seeker
Posts: 21
Default Sony STR-AV19 Left Channel weak when quiet?

I have a Sony STR-AV19 that works great when the music is on the loud side. But if things get quiet, I start to loose the left channel. It gets quiet and a little fuzzy sounding. It does the same thing no matter what the physical position of the volume knob is. It also seems to get worse if I have it running for a couple hours. I've had it taken apart and I don't see any visible damage. The service manual is available here: http://sportsbil.com/sony/STR/STR-A/STR-AV19.pdf

Does anyone have any ideas where I should start looking? The volume knob sounds clean, so I don't think it's the potentiometer.

-Thanks
macjedimatt is offline   Reply With Quote
Old 10-30-2020, 03:56 PM   #2
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 4,638
Default Re: Sony STR-AV19 Left Channel weak when quiet?

compare the left channel to the right channel when its acting up. look with an oscilloscope on which stages of amplification things are normal or not. look also for bad solder joints and make sure that all voltage rails are good.
CapLeaker is offline   Reply With Quote
Old 11-10-2020, 03:00 PM   #3
jons
New Member
 
Join Date: Feb 2014
City & State: Riga
My Country: Latvia
I'm a: Knowledge Seeker
Posts: 18
Default Re: Sony STR-AV19 Left Channel weak when quiet?

Check output relay - if their contacts oxidize enough to make some resistance between them then amp can act like this.
jons is offline   Reply With Quote
Old 11-10-2020, 08:53 PM   #4
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 6,611
Default Re: Sony STR-AV19 Left Channel weak when quiet?

Try pushing the speaker switch a few times to clean the contacts to see if that helps, if not then a scope would be needed to trace and compare the audio signal.
Try the tone and balance controls as well to see if they have any effect on the low audio.
R_J is offline   Reply With Quote
Old 01-11-2021, 03:01 PM   #5
macjedimatt
Member
 
Join Date: May 2012
City & State: Dracut, MA
My Country: USA
I'm a: Knowledge Seeker
Posts: 21
Default Re: Sony STR-AV19 Left Channel weak when quiet?

I finally figured out what the issue was. The speaker protection relay has bad contacts. I've by-passed it for now and will eventually order a new one to replace it since cleaning the contacts didn't help at all.
macjedimatt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:01 AM.
Did you find this forum helpful?