Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-01-2020, 02:06 PM   #1
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Samsung UA55EH6030MXSQ Bad LCD Display

hey all ,

one day me screen gone crazy , i searched google and youtube for solution and figured out its probably the T con board , i ordered a replacement board from ShopJimmy , replaced the one in my TV but nothing changed .

when i turn it on first it turns on , then off and then on.

i excamented the electronics and everything looks to be ok .

i put video on youtube showing the issue

https://www.youtube.com/watch?v=L3HoWrGYlwY

does any one have a clue what might be the problem and how to fix it ?

thanks
D
Attached Images
File Type: jpg image.jpg (89.1 KB, 17 views)
File Type: png image (1).png (1.23 MB, 3 views)
Rufos86 is offline   Reply With Quote
Old 11-01-2020, 04:11 PM   #2
neilc6
Badcaps Veteran
 
Join Date: Nov 2015
City & State: BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,006
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Probably a bad panel and not repairable. You can power up the TV with only one side of the TV connected between the tcon and panel. If one side shows a good picture, the panel fault is on the bad side.
neilc6 is offline   Reply With Quote
Old 11-01-2020, 06:46 PM   #3
Kilroy2k1
Member
 
Join Date: Aug 2009
City & State: Ontario Canada
Posts: 62
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Could be a bad cap or resistor on the panel driver boards.
Kilroy2k1 is offline   Reply With Quote
Old 11-01-2020, 11:30 PM   #4
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Quote:
Originally Posted by neilc6 View Post
Probably a bad panel and not repairable. You can power up the TV with only one side of the TV connected between the tcon and panel. If one side shows a good picture, the panel fault is on the bad side.
Hey , already tried it , disconnected one side and checked the screen and then did the same for the other cable , the result remain the same , there is no difference .
Rufos86 is offline   Reply With Quote
Old 11-01-2020, 11:58 PM   #5
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Quote:
Originally Posted by Kilroy2k1 View Post
Could be a bad cap or resistor on the panel driver boards.

is that the board with all the connections HDMI etc ?


thanks
D.
Rufos86 is offline   Reply With Quote
Old 11-02-2020, 02:51 AM   #6
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 6,020
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

No, it's the thin board between the tcon and the panel.
nomoresonys is offline   Reply With Quote
Old 11-02-2020, 07:53 AM   #7
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Quote:
Originally Posted by nomoresonys View Post
No, it's the thin board between the tcon and the panel.

thanks, ill check for shorts and update .

D.
Rufos86 is offline   Reply With Quote
Old 11-03-2020, 08:01 AM   #8
Robrokr
New Member
 
Join Date: Nov 2020
City & State: Liverpool
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 2
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

I have had a few power cycle and freezing the nand chip to -40 will give you enough time to update the system, I'm on a ue55d now and it was doing the same but wasnt the nand chip it was a bad connection on the led board and the power ic was shutting it down. When it boots switch off all the lights and video the screen and check all sections are lit.
Robrokr is offline   Reply With Quote
Old 11-03-2020, 01:46 PM   #9
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Quote:
Originally Posted by Robrokr View Post
I have had a few power cycle and freezing the nand chip to -40 will give you enough time to update the system, I'm on a ue55d now and it was doing the same but wasnt the nand chip it was a bad connection on the led board and the power ic was shutting it down. When it boots switch off all the lights and video the screen and check all sections are lit.
hey , thanks for the tip.

Quote:
I have had a few power cycle and freezing the nand chip to -40 will give you enough time to update the system
can you explain that ? didn't really get it

and what exactly is the nand chip ? is it the one on the t con board ?

how eventually did you manged to fix your TV ?

thanks
D
Rufos86 is offline   Reply With Quote
Old 11-03-2020, 06:23 PM   #10
Robrokr
New Member
 
Join Date: Nov 2020
City & State: Liverpool
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 2
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

Saying that just looked your picture and it looks like the ribbons attached to the bottom off tor lcd panel might have come unstuck abit, try pressing on them with a plastic card and see if that helps.

Last edited by Robrokr; 11-03-2020 at 06:29 PM..
Robrokr is offline   Reply With Quote
Old 11-06-2020, 04:49 AM   #11
Rufos86
New Member
 
Join Date: Nov 2020
City & State: tel aviv
My Country: israel
I'm a: Knowledge Seeker
Posts: 7
Default Re: Samsung UA55EH6030MXSQ Bad LCD Display

hey all , just finished checking the TV - Again .

no shorts on any of the components on the LCD panel board .
cleaned the ribbon cable connectors with ipa .
disconnected one side and then the other side .
t-Con replace with new one
checked all the connectors for burn marks

i really don't know what else might be the problem . should i just get a new TV and that's it ?

thats how it looks now with the chromecast connected

Rufos86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:25 PM.
Did you find this forum helpful?