Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-06-2022, 03:54 PM   #1
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Need some help with Epson Printer Power Supply C655 MAIN

Here is the back story. This printer had been sitting for about two years not used. I removed the print head to clean it (completely dried out). I cleaned it and reinstalled in. Powered the printer on, the printer started going through it's normal start-up procedure and part way through it was like the power just shut off. No sound, not lights, no error messages, it just went completely off. I suspect the power supply.

At any rate, the schematic for the power supply is included.

There is a lot going on on the low voltage side that I am not able to make heads or tails out of! I believe the stand-by power is derived on the low voltage side.

I have tried doing some initial testing with the supply removed and could not really tell much as I was not able to get it out of stand-by mode. The fuse is good and I'm getting power into and out of the rectifier.

One thing I have discovered, if I reconnect the supply to the processor board, I hear sort of a high-pitched "beep" sound from the supply. I believe the supply is attempting to start up but them shuts down. After doing more testing last night, I discovered that R12 looked "chalky" colored, I believe it was blue, or light blue at some point. I pulled it and it measured 1.2 ohms. According to the schematic, it should be 0.3 ohms. I didn't have a 1 watt resistor so I had to order one.

On the output I have nothing, no +42v, no +5v and no +3.3v.

Can you folks help me get this supply working again? I would greatly appreciate your help.
Attached Files
File Type: svg Epson Power Supply.svg (655.1 KB, 16 views)
UglyBetty is offline   Reply With Quote
Old 01-06-2022, 05:41 PM   #2
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,101
Default Re: Need some help with Epson Printer Power Supply.

R12 (0.3Ω) is likely good, you were also measuring the meter leads resistance.
Quote:
I have tried doing some initial testing with the supply removed and could not really tell much as I was not able to get it out of stand-by mode. The fuse is good and I'm getting power into and out of the rectifier.
There is more than one rectifier, which one are you talking about?

Quote:
One thing I have discovered, if I reconnect the supply to the processor board, I hear sort of a high-pitched "beep" sound from the supply
There could be something shorted on the processor board.

Last edited by R_J; 01-06-2022 at 05:50 PM..
R_J is offline   Reply With Quote
Old 01-06-2022, 08:52 PM   #3
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply.

R_J ---Thanks so much for your reply.

I have measured other sub-ohm resistors and the leads did not add this much resistance (if any). I'm using a Fluke DVOM meter and meter leads. Leads touched together have 0.00 resistance.

The rectifier I've measured is the bridge rectifier.

I've thought about that, I also thought about it being in one of the other step-down boards located around the printer. I removed the main board from the printer and connected the power supply. With nothing connected to the supply, it still continues to do the same thing.

I guess the only way of eliminating the everything but the supply is to figure out how to "tun it on" while not connected to the main board. On second thought, I guess the short, if there is one, would be in the stand-by system seeing as that is the only thing being used when the power button is in the off position. Correct?
UglyBetty is offline   Reply With Quote
Old 01-07-2022, 09:27 AM   #4
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 5,175
Default Re: Need some help with Epson Printer Power Supply.

To me, the power supply should produce some sort of voltage by itself. I don't think the mains is switched to turn the PSU on and off.
CapLeaker is offline   Reply With Quote
Old 01-07-2022, 10:27 AM   #5
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply.

Thanks CapLeaker.
If you look at the schematic, on the output side, connector CN2, pin 5 of that connector is labeled "PSC". If I'm not mistaken, that stands for Power Supply Control. Studying the rest of the schematic, this is used by the processor to turn on and off the power supply.
Pin 9 labeled "ESAVE" I believe is used by the controller to put the printer into some sort of "sleep" mode or "stand-by" mode. Just in my limited knowledge and some reading I have done, I believe this is part of some sort of Energy Star power saving system?
I could be very wrong, and you may be correct that the power supply is on all the time. But, it will not power up if not connected to the processor board for some reason.
Do you see a reason looking at the schematic that it would not power up?
UglyBetty is offline   Reply With Quote
Old 01-07-2022, 11:40 AM   #6
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,101
Default Re: Need some help with Epson Printer Power Supply.

First check what voltage you are getting across C51/C52, You should have some voltage here. Next check the voltage across C12 in the primary, What is this voltage?
The power supply is always on, but in standby it should be in burst mode. so the 42v line would be low maybe around 20vdc
R_J is offline   Reply With Quote
Old 01-07-2022, 07:17 PM   #7
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply.

Voltage across C51/C52 is 0volts, but it pulses up to between 1-3 when the supply comes on, immediately drops to 0 volts when the supply kicks back off.

Voltage across C-12 is a steady 165.

I measured the resistance between the +42 volt output and ground. 0.3 ohms. I would say I have a direct short somewhere on the main board!

I am guessing my hunch about the power supply was incorrect. There are several caps on the main board. I am wondering if one of those is shorted.

It does not appear any of them have leaked or are bulging.
Attached Images
File Type: jpg IMG_6878.jpg (1.47 MB, 17 views)
UglyBetty is offline   Reply With Quote
Old 01-07-2022, 07:57 PM   #8
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,101
Default Re: Need some help with Epson Printer Power Supply.

The voltage measure across C12 is wrong, it is obvious you used the secondary ground and not the hot ground. 165 volts across C12 would mean the cap and the ic would be in orbit.
Yes you have a short on the +42 volts. Is this short only when the main board is connected? because if it is I am supposed that the fuse F51 didn't open.

If you look at the primary side, C11 negative is HOT or PRIMARY ground. it is not connected to the secondary ground. So when checking voltages in the primary side of T1 you must use hot ground.
Is there a schematic for the main board?

Last edited by R_J; 01-07-2022 at 08:04 PM..
R_J is offline   Reply With Quote
Old 01-07-2022, 08:02 PM   #9
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply.

On C12, I just measured across the leads of the cap.

I disconnected the power supply from the main board and measured the ohm value across the +42 volt terminal and to the one of the ground terminals. It measures 0.3 ohms. I would say it's on the main board.

May just replace the main board and be done with it.....
UglyBetty is offline   Reply With Quote
Old 01-07-2022, 08:18 PM   #10
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,101
Default Re: Need some help with Epson Printer Power Supply.

Quote:
Originally Posted by UglyBetty View Post
On C12, I just measured across the leads of the cap.

I disconnected the power supply from the main board and measured the ohm value across the +42 volt terminal and to the one of the ground terminals. It measures 0.3 ohms. I would say it's on the main board.

May just replace the main board and be done with it.....
C12 is a 25v volt capacitor and you measured 165volts across it? I don't think so.
With power supply disconnected from the main board you measured the short on the MAIN BOARD correct?
Check if Q10 and Q11 are shorted, If they are not shorted, IC2 regulator may be shorted, there are a number of capacitors and ic's that connect to the +42v supply.

Last edited by R_J; 01-07-2022 at 08:34 PM..
R_J is offline   Reply With Quote
Old 01-08-2022, 07:27 AM   #11
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 5,175
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

that should be a sweet repair... 42V on the main board shorted. Got to be one of the fets or the regulator as RJ already pointed out.
CapLeaker is offline   Reply With Quote
Old 01-08-2022, 09:34 AM   #12
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

This was driving me crazy last night so I did some more digging. I just couldn't walk away from it. I'm a seasoned professional mechanic for a living and I know the importance of proper diagnosis. I also know you can learn a tremendous amount from failure analysis. So I kept going.

I found two transistors on the main board that appear to be shorted. I included a portion of the schematic of the main board. I'm posting this from my laptop and don't have a full copy of acrobat in it so I just did a screen shot of that portion of the schematic. I can post the full one page schematic of the main board if that would help.

The two transistors circled in red appear to be shorted. I removed them from the board and measured across the C and E, 0.3 ohms. I remeasured the +42volt input again and my short is gone.

My question is, what the hell caused these to fail? From the data sheets, they appear to be rated at 15 AMPS!! WOW! That's a lot of power.

The kicker here is, the chip associated with these transistors controls the................wait for it............PRINT HEAD!!! So looks I may have screwed something up in that during my cleaning.......DOE!!!!
Attached Images
File Type: png Screen Shot 01-08-22 at 09.23 AM.PNG (144.5 KB, 11 views)
UglyBetty is offline   Reply With Quote
Old 01-08-2022, 09:54 AM   #13
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

Something else fun! I put it all back together, minus the transistors, jumper GRD and PSC, I get my +43v, +5v and +3.3v back from the power supply!! Guess the transistors were the short...
What do you think? Replace the transistors and try again? Or order the main board and a print head? Main board is about $60 and the print head is around $55, used, from China of course....
I'm not ready to give up on this printer. Seems to be worth $600-$700 used.
UglyBetty is offline   Reply With Quote
Old 01-08-2022, 11:43 AM   #14
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 5,175
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

Replace the transistors. Look up the specs and match something…it doesn’t have to be the exact same part number. Now check R164 to GND and see if there is a short or not. Maybe something else is bad that is on that rail where the transistors output on that made the transistors go short (like the print head shorted), or the transistors just failed. Could be that IC10 is bad too. Now… where these transistors shorted all way around between the 3 legs?

Last edited by CapLeaker; 01-08-2022 at 11:54 AM..
CapLeaker is offline   Reply With Quote
Old 01-08-2022, 12:51 PM   #15
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

I'll see if I can find something with the same specs, replace them and see if I can make it work.
I checked the R164. In circuit, it measures 2.4 ohms, going through that resister, through C129, measure 26.4K to ground.
Oh, and yes, all three C, E and B of the two transistors are shorted together. 0.3 ohms between each contact, regardless of test lead connections.

Last edited by UglyBetty; 01-08-2022 at 12:56 PM..
UglyBetty is offline   Reply With Quote
Old 01-08-2022, 12:54 PM   #16
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply.

Quote:
Originally Posted by R_J View Post
C12 is a 25v volt capacitor and you measured 165volts across it? I don't think so.
With power supply disconnected from the main board you measured the short on the MAIN BOARD correct?
Check if Q10 and Q11 are shorted, If they are not shorted, IC2 regulator may be shorted, there are a number of capacitors and ic's that connect to the +42v supply.
C12 is a 250v cap., not 25v.
Yes, I measured a short of 0.3 ohms across the +42 volt supply connections and ground.

Edit; Sorry, you are correct, I was thinking C11, not C12. Your right, it is 25v. honestly, I don't think I measured that one. Anyhow, I believe I have located the problem, but I DO thank you for your help. As you can tell, I know just enough to be dangerous!

Last edited by UglyBetty; 01-08-2022 at 01:00 PM..
UglyBetty is offline   Reply With Quote
Old 01-08-2022, 01:12 PM   #17
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,101
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

I suspect you may have caused the problem somehow as the transistors that are shorted drive the print head, there are two cables CN10 & CN11, did you maybe reverse them or damage the flex cable?
CN11 has ground pins on either side of the print drive coming from Q10/11

Last edited by R_J; 01-08-2022 at 01:37 PM..
R_J is offline   Reply With Quote
Old 01-08-2022, 01:44 PM   #18
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

Quote:
Originally Posted by R_J View Post
I suspect you may have caused the problem somehow as the transistors that are shorted drive the print head, there are two cables CN10 & CN11, did you maybe reverse them or damage the flex cable?
CN11 has ground pins on either side of the print drive coming from Q10/11
I wondered that myself. I numbered all of the small ribbon cables I removed from the main board to the rest of the printer. then I photographed them as I was removing them. The way the cables lay in the printer, they are pretty tight fit. I would be very difficult to get any of them in the wrong place, but I guess anything is possible. I just wonder if there was water or cleaning fluid in the circuit board located on the printhead and when I connected everything back up that water/cleaning fluid shorted out the board in the printhead, and that took out the main board. That is really the only thing I can come up with.
I have a tested good main board and tested good print head ordered from China...Next year, I should have it...lol!!

Frustrating, let me tell ya, thinking I am the idiot who let the smoke out!!
UglyBetty is offline   Reply With Quote
Old 01-08-2022, 01:46 PM   #19
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

Thanks EVERYONE for your help! You guys/gals are awesome! I'm going to call this one for now. I'll post an update when I get the "stuff" in and get it going again.
UglyBetty is offline   Reply With Quote
Old 01-09-2022, 10:12 AM   #20
UglyBetty
Member
 
Join Date: Jan 2022
City & State: Edmond, Oklahom
My Country: USA
I'm a: Knowledge Seeker
Posts: 20
Default Re: Need some help with Epson Printer Power Supply C655 MAIN

Just for the heck of it, I ordered some transistors to see if I can screw up this board even more! This should be fun! Stay tuned....
UglyBetty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:08 PM.
Did you find this forum helpful?