Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-28-2021, 10:14 AM   #1
sdinelli
Sdinelli
 
Join Date: Aug 2014
City & State: Delaware
My Country: USA
Line Voltage: 120VAC
I'm a: Hobbyist Tech
Posts: 119
Default 1300W PSU - Help with replacement mosfet

Hey guys,
had this 1300W gigabit PSU with a blown fuse ( i actually have two with the same problem.)
I found a shorted power mosfet and diode and some low Ohm resistors that measure 0Ohm.
I cant find the data sheet on this mosfet at all. need help finding replacement.
any help would be great.
I was able to find this on the mosfet but thats all
https://www.aliexpress.com/i/32967081176.html
Attached Images
File Type: jpg 63564305544__7B6BFD56-88BC-48A1-8396-135064802074.jpg (572.8 KB, 48 views)
File Type: jpg IMG_1523.jpg (638.6 KB, 50 views)
File Type: jpg IMG_1524.jpg (380.4 KB, 47 views)
File Type: jpg IMG_1525.jpg (393.1 KB, 37 views)
sdinelli is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:44 AM.
Did you find this forum helpful?