Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 08-25-2019, 05:47 PM   #121
emadarion
Member
 
Join Date: Jun 2017
City & State: Egypt
My Country: Cairo
I'm a: Knowledge Seeker
Posts: 26
Default Re: Asus Q502L does not boot up properly

Thank you for sharing, very detailed, to see more times to remember
emadarion is offline   Reply With Quote
Old 07-18-2020, 09:42 PM   #122
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Still not done with this laptop. I have purchased a used board from the bay, installed a brand new Samsung ssd, installed Windows 10 and all seemed fine for a few days. I have put it away for a few weeks.
After awhile I have grabbed it, and it started acting up.
What's in a while would not "see" the ssd and would boot into BIOS. If I rebooted, eventually would boot and work OK for a while.
Now more often goes to BIOS, then in Windows.
Replaced memory, HDD even the small daughter board for the HDD, still no change.
Has the latest BIOS, all the updated, Windows 10 2004 and all.
Any suggestion what should I do with it. Sometimes goes into blue screen as well.
tibimakai is offline   Reply With Quote
Old 08-04-2020, 09:00 AM   #123
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Nobody has encountered a disappearing HD situation, what could be?
tibimakai is offline   Reply With Quote
Old 08-05-2020, 09:09 PM   #124
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

If I plug in a 2.5" HDD it shows the Sata port 0 as Empty.
If I plug in an msata SSD, it shows Sata port 2 as Empty.
If I don't plug in any HDD, shows all Sata ports Sata 0, #1, #2, #3, #4
They all show Empty.
What could be the problem here?
What controls the Sata ports? The CPU, or there is a separate Sata controller?
Any help would be greatly appreciated.
tibimakai is offline   Reply With Quote
Old 08-06-2020, 12:07 AM   #125
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

It stopped recognizing any HDDs.
tibimakai is offline   Reply With Quote
Old 08-09-2020, 12:57 AM   #126
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 421
Default Re: Asus Q502L does not boot up properly

if its not recognizing any ssd hdd try to clean the connectors. try to reinsert it.. try to boot using usb does it recognized the usb drive....do you happen to check the rtc battery maybe its way too low..
__________________
Never stop LEARNING because life never stops TEACHING!
Duranitron is offline   Reply With Quote
Old 08-09-2020, 02:38 AM   #127
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

I have even replaced the hdd daughter board, so it is hard to believe that the connector is causing these issues.
I will check the connector, just in case.
It recognizes a USB stick. Starts installing Windows, but it won't find a hdd.
I haven't checked the battery, but it holds the date.
tibimakai is offline   Reply With Quote
Old 10-04-2020, 07:12 PM   #128
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

It's been a while since I have looked at this laptop, but I have just had a bulb turn on above my head.
The laptop hard drive, has to have a 12V supply as well, other than 3.3V and 5V supply?
I don't have it.
No matter what I try, HDD won't show in BIOS.
I would appreciate any help.
tibimakai is offline   Reply With Quote
Old 10-05-2020, 01:09 AM   #129
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,595
Default Re: Asus Q502L does not boot up properly

No, 2.5" laptop HDD don't use 12V.
__________________
OpenBoardview http://openboardview.org | IRC #[email protected]
piernov is offline   Reply With Quote
Old 10-05-2020, 02:13 AM   #130
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

What else could be, that no hdd shows up in the BIOS? 3.3V and 5V is there.
tibimakai is offline   Reply With Quote
Old 10-05-2020, 08:13 PM   #131
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

There is only the ITE IC and the CPU on this board. What could cause this issue?
BGA solder issue at the CPU?
Attached Images
File Type: jpg Q502LA-1.jpg (355.0 KB, 8 views)
File Type: jpg Q502LA-2.jpg (335.9 KB, 6 views)
tibimakai is offline   Reply With Quote
Old 10-09-2020, 09:11 AM   #132
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Nobody can help?
tibimakai is offline   Reply With Quote
Old 10-28-2020, 01:49 PM   #133
FrozenHaxor
Senior Member
 
Join Date: Jun 2015
City & State: Warsaw
My Country: Poland
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 147
Default Re: Asus Q502L does not boot up properly

Most likely cause is the PCH part of the CPU is bad, it controls SATA I/O directly.
FrozenHaxor is offline   Reply With Quote
Old 10-28-2020, 01:52 PM   #134
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Can't be solder balls cracking?
Thank you, for your reply.
How "easy" is to replace the CPU?
tibimakai is offline   Reply With Quote
Old 10-29-2020, 08:25 AM   #135
FrozenHaxor
Senior Member
 
Join Date: Jun 2015
City & State: Warsaw
My Country: Poland
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 147
Default Re: Asus Q502L does not boot up properly

I have a BGA machine with optical system and it takes lots of experience to do it right. Intel CPUs are notorious for doing a "banana" and warping on cooldown, I avoid replacing them like a plague. I usually condemn boards that need this repair as it's not worth it most of the time, and new CPU itself will cost more than complete used working board in this case. If you suspect cracked BGA soldering then you could do a reflow, but all of the glue needs to go before doing it, and you still need a BGA rework station to avoid warping, especially on cooldown. If the laptop wasn't dropped and there was no physical shock to the mainboard, it is most likely internal PCH fault and they are notorious for such problems, even Intel admitted so years ago.
FrozenHaxor is offline   Reply With Quote
Old 10-29-2020, 08:57 AM   #136
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Most likely I won't reball the CPU, just reflow it.
What is interesting, that initially when I got the board from Ebay, it was working great, I have installed Windows, and it worked.
After a while, it started to act up, sometimes it would not recognize the hdd, but a reboot took care of that. This started to become more frequent, until it would not recognize it at all.
tibimakai is offline   Reply With Quote
Old 10-29-2020, 09:29 AM   #137
FrozenHaxor
Senior Member
 
Join Date: Jun 2015
City & State: Warsaw
My Country: Poland
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 147
Default Re: Asus Q502L does not boot up properly

Does your HDD connect directly to the mainboard via ribbon or is there a daughter board with connector that mates to the mainboard?
FrozenHaxor is offline   Reply With Quote
Old 10-29-2020, 10:01 AM   #138
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Daughter board. I have already purchased another one, and it is still the same issue.
tibimakai is offline   Reply With Quote
Old 10-29-2020, 12:05 PM   #139
FrozenHaxor
Senior Member
 
Join Date: Jun 2015
City & State: Warsaw
My Country: Poland
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 147
Default Re: Asus Q502L does not boot up properly

Did you inspect the other part of the connector on the mainboard? Some Asus boards are prone to failures of them causing odd issues. If it's okay then it's a PCH problem.
FrozenHaxor is offline   Reply With Quote
Old 10-29-2020, 12:06 PM   #140
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,433
Default Re: Asus Q502L does not boot up properly

Yes, I have when over with the solder iron.
tibimakai is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:36 PM.
Did you find this forum helpful?