Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-28-2020, 06:29 PM   #1
brumbrum
New Member
 
Join Date: Sep 2016
City & State: Italy
My Country: Italy
I'm a: Knowledge Seeker
Posts: 14
Exclamation 820-3437-B no light and fan spinning fast

Good morning everyone,
I Have a MacBook air logic board that first came in for no power.
I removed ssd and wireless card.
With charger I got only orange light, and if I press power button the light became green just for 2 seconds (the system feels when I press power button).
The issue it's: no boot, no power on, I have v core, 1.7v, but as I plug the charger, green light 2 seconds and orange light with fan stuck spinning.
Nothing except cpu on board is hot, no corrosion, I haven't found any short, and I checked that voltage rails checked and are ok:

 PM_SLP_S5_L – 3.3v
 PPBUS_G3H
 PPBUS_S5_HS_COMPUTING_ISNS
 PPBUS_S5_HS_OTHER_ISNS PP5V_S5
 PP5V_S4RS3
 PP5V_S0
 PP3V3_S5
 PP3V3_S4
 PP3V3_S3
 PP3V3_S0
 PP1V8_S3
 PP3V42_G3H
 PPVRTC_G3H
 PP5V_S5
 PP5V_S4RS3
 SMC_ADAPTER_EN
 PCH_SRTCRST_L

Issues:

 PM_SLP_S4_L -> 0v
 PM_SLP_S3_L -> 0v


Can someone help me to fix that crazy board? thank you

Last edited by brumbrum; 10-28-2020 at 06:45 PM..
brumbrum is offline   Reply With Quote
Old 10-28-2020, 07:59 PM   #2
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,595
Default Re: 820-3437-B no light and fan spinning fast

Keyboard is probably bad.
If you have S3 and S0 rails present, PM_SLP_S4_L and PM_SLP_S3_L cannot be 0V.
__________________
OpenBoardview http://openboardview.org | IRC #[email protected]
piernov is offline   Reply With Quote
Old 10-29-2020, 03:43 AM   #3
brumbrum
New Member
 
Join Date: Sep 2016
City & State: Italy
My Country: Italy
I'm a: Knowledge Seeker
Posts: 14
Default Re: 820-3437-B no light and fan spinning fast

But I've disassembled the board, with only magasafe connected, and problem is still the same
brumbrum is offline   Reply With Quote
Old 10-29-2020, 04:45 AM   #4
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,595
Default Re: 820-3437-B no light and fan spinning fast

With a good keyboard it shouldn't cause Magsafe light to turn green then orange again when pressing power button (could also be caused by touchpad but less likely).
It's not clear what the problem is though. Your measurements don't really make sense and you haven't properly described the symptoms. You say no power but at the same time "fan stuck spinning" and CPU getting hot.
So, with only the board: orange light on Magsafe? Fan spinning?
With a USB drive plugged in, activity LED blinking?
Chiming with speakers connected?
Image and backlight with LCD connected?
piernov is offline   Reply With Quote
Old 10-29-2020, 06:03 AM   #5
brumbrum
New Member
 
Join Date: Sep 2016
City & State: Italy
My Country: Italy
I'm a: Knowledge Seeker
Posts: 14
Default Re: 820-3437-B no light and fan spinning fast

ok I'm sorry. I'm trying now to explain better now after Smc replacing.
No power with battery connected, no sign of life. No chiming or any sound, no image and no backlight.
If I plug magsafe, I get green led and fan spinning for 2 seconds, after that fan stop and led became orange. With orange led, fan keep spinning stuck at the same speed, and only cpu is hot, and of course no chiming or any sound, no image and no backlight.
With a USB drive plugged in, activity LED not blinking.
The behaviour of the board is the same, with or without keyboard and touchpad connected.
brumbrum is offline   Reply With Quote
Old 10-29-2020, 07:40 AM   #6
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,595
Default Re: 820-3437-B no light and fan spinning fast

So with logic board, DC-in board and fan: fan spins, stops and spins again?
This board should have fan spin, stop, spin, stop and then spin again instead.
So you replaced the SMC? What led you to replacing the SMC? Did you take the SMC from same model donor board?
piernov is offline   Reply With Quote
Old 10-29-2020, 11:31 AM   #7
brumbrum
New Member
 
Join Date: Sep 2016
City & State: Italy
My Country: Italy
I'm a: Knowledge Seeker
Posts: 14
Default Re: 820-3437-B no light and fan spinning fast

I already replaced the smc cause under microscope I noticed that there was a little "ball" (like blow up) on the chip, even if under the chip everything was ok.
I didn't have a similar donar board to take it from, so I bought a new one with similar number:

the new one:
LM4FS1BH 5BBCIG 48A491W

the old one:
LM4FS1BH 5BBCIG 33A6GSW

But the issue is the same.
brumbrum is offline   Reply With Quote
Old 10-29-2020, 12:09 PM   #8
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,595
Default Re: 820-3437-B no light and fan spinning fast

SMC must come from same model donor board. It has a firmware that's specific to the board model.
piernov is offline   Reply With Quote
Old 10-29-2020, 03:22 PM   #9
brumbrum
New Member
 
Join Date: Sep 2016
City & State: Italy
My Country: Italy
I'm a: Knowledge Seeker
Posts: 14
Default Re: 820-3437-B no light and fan spinning fast

oh, thank for this info. so, it was my mistake, I didn't know it. Now should I buy another one already programmed for this model? or can I program it in any way?
brumbrum is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:02 PM.
Did you find this forum helpful?