Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-03-2019, 09:37 AM   #81
on/off
Badcaps Veteran
 
on/off's Avatar
 
Join Date: Oct 2016
City & State: Forbidden
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 326
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by IamPritesh View Post
What I noticed is that that on one side of PR290 I now have 19V ( VIN) and the other side it has around 6.5 volt. Is that normal ?
Should be half of voltages of VIN

Quote:
Originally Posted by IamPritesh View Post
I replaced the 1M resistor (PR290) and now we have 15VPCU showing correct voltage of 15V
Good news..

Have you check PGOOD1 after 15VPCU get normal?

Also we need to know about RTC_RST# and SRTC_RST# and ACIN.

Last edited by on/off; 02-03-2019 at 09:40 AM..
on/off is offline   Reply With Quote
Old 02-03-2019, 09:42 AM   #82
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by on/off View Post
Should be half of voltages of VIN



Good news..

Have you check PGOOD1 after 15VPCU get normal?

Also we need to know about RTC_RST# and SRTC_RST# and ACIN.

Yes i think we are progressing in the right direction

NO PGOOD1 yet because there is no MAIND signal to power the EC with +3V
IamPritesh is offline   Reply With Quote
Old 02-03-2019, 10:21 AM   #83
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by on/off View Post
Should be half of voltages of VIN
Interesting. In that case why PR272 shows 19V on VIN side and on the other side it shows no voltage after adapter is plugged in.
ACIN voltage is 3.3

Last edited by IamPritesh; 02-03-2019 at 10:29 AM..
IamPritesh is offline   Reply With Quote
Old 02-03-2019, 10:28 AM   #84
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Also what should be the ideal voltages on gate of PQ67 and and PIN2 of PQ68 before the power button is pressed.

I also want to thank you for supporting me this far. You all are amazing.
IamPritesh is offline   Reply With Quote
Old 02-03-2019, 09:04 PM   #85
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Would appreciate if you anyone can share their valuable inputs when they have some time.

Thanks
IamPritesh is offline   Reply With Quote
Old 02-03-2019, 09:10 PM   #86
on/off
Badcaps Veteran
 
on/off's Avatar
 
Join Date: Oct 2016
City & State: Forbidden
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 326
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Actually didn't know power sequence on this model (HK1) a bit different with HK8 (mostly come to my bench) S5_ON signal turn ON after pressing PwrBTN. While HK1 seem S5_ON turn ON (actually on your board) after plugin adapter.

What I've been thought that First EC need supplied by 3.3V, for purpose this only need EN2 ON and OUT2 present. Meanwhile EN1 (S5_ON) delayed or after by Pressing PwrBTN, this could be happen. Even if bios didn't supplied by 3V providing that EC got supply it could be. If HK1 should be like this, so S5_ON seem this signal premature.

Found Power of sequence but don't know is correct or not.
Attached Files
File Type: pdf HK1_HK2 - PsQ.pdf (16.9 KB, 16 views)
on/off is offline   Reply With Quote
Old 02-03-2019, 09:11 PM   #87
on/off
Badcaps Veteran
 
on/off's Avatar
 
Join Date: Oct 2016
City & State: Forbidden
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 326
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by IamPritesh View Post
Also what should be the ideal voltages on gate of PQ67 and and PIN2 of PQ68 before the power button is pressed.

I also want to thank you for supporting me this far. You all are amazing.
A pair resistor as voltage divider, then the value Gate PQ67 should be 8-9V, this in state DISCHARGE. (all voltages S3-S0 discharge)

Last edited by on/off; 02-03-2019 at 09:14 PM..
on/off is offline   Reply With Quote
Old 02-03-2019, 09:18 PM   #88
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by on/off View Post
A pair resistor as voltage divider, then the value Gate PQ67 should be 8-9V, this in state DISCHARGE. (all voltages S3-S0 discharge)
The gate of PQ67 is 6.5 volt.
IamPritesh is offline   Reply With Quote
Old 02-03-2019, 09:20 PM   #89
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Yes S5_ON has 3.3 volt as soon as adpater is plugged in.
PR272 shows 19V on VIN side and on the other side it shows no voltage after adapter is plugged in. Is that normal ? RVCCD does generate just fine.
IamPritesh is offline   Reply With Quote
Old 02-04-2019, 12:19 PM   #90
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Anyone has any suggestion as what should I check next. I think we have progressed well so far after we have achieved 15VPCU.

Wondering why Pgood1 is not generated on PU9
Thanks.
IamPritesh is offline   Reply With Quote
Old 02-05-2019, 08:58 AM   #91
on/off
Badcaps Veteran
 
on/off's Avatar
 
Join Date: Oct 2016
City & State: Forbidden
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 326
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

I don`t see you mention about RTC...post#81.

What about VCC_POR# pin 85 NPCE?
on/off is offline   Reply With Quote
Old 02-05-2019, 10:37 AM   #92
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Professional Tech
Posts: 1,272
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by IamPritesh View Post
Anyone has any suggestion as what should I check next. I think we have progressed well so far after we have achieved 15VPCU.

Wondering why Pgood1 is not generated on PU9
Thanks.
For the PGOOD1 test the pin 11 of PU9 Voltage(2.5V)? + test PR148/150 , this is the feedback of 5V to PU9

Last edited by techtiger; 02-05-2019 at 10:42 AM..
techtiger is offline   Reply With Quote
Old 02-05-2019, 09:05 PM   #93
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

I noticed that 3V was generating fine but 5V was not generating as it should. The output of COIL PL14 had 5V but the input side showed no voltage. 3.3 volt was generating just fine.

I tried replacing the PU9 IC and now I dont even have the 3.3 volt. What could have gone wrong ?
IamPritesh is offline   Reply With Quote
Old 02-06-2019, 03:26 AM   #94
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Professional Tech
Posts: 1,272
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

may be bad soldering test vin
pin 6
pin 7 LDO
pin 32
pin 3
pin 19

Last edited by techtiger; 02-06-2019 at 03:31 AM..
techtiger is offline   Reply With Quote
Old 02-06-2019, 08:16 AM   #95
IamPritesh
Badcaps Veteran
 
Join Date: Aug 2017
City & State: India
My Country: India
I'm a: Knowledge Seeker
Posts: 227
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by techtiger View Post
may be bad soldering test vin
pin 6
pin 7 LDO
pin 32
pin 3
pin 19


yeah it was indeed bad soldering but now I have resoldered it almost pretty good but no luck.

Pin 6 - 19V
Pin 4 - 5.5
Other pins have no voltage.

Have I damaged this IC due to bad soldering?
IamPritesh is offline   Reply With Quote
Old 10-07-2019, 06:42 AM   #96
menshawy
Senior Member
 
Join Date: Aug 2013
City & State: cairo
My Country: egypt
I'm a: Knowledge Seeker
Posts: 177
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Quote:
Originally Posted by on/off View Post
  • +3V_SPI come from +3V_S5 via R61 (short pad), When PQ44 ON require trigger from RVCCD (approx 12V).
  • S5_ON generated 15VPCU be RVCCD.
  • Maybe bios not working had effect KBC not work well.
thanks
menshawy is offline   Reply With Quote
Old 09-04-2020, 10:39 AM   #97
musanide
New Member
 
Join Date: May 2020
City & State: ndola
My Country: zambia
Line Voltage: 220VAC
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony MBX 247 Laptop Dead. Need help ( Pics attached )

Please help . I also have the same board and am not understanding the meaning of 15vpcu.. Please explain to me coz am missing 5v rail only having 2.4v
musanide is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:41 PM.
Did you find this forum helpful?