Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-16-2015, 12:37 PM   #1
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Sony KDL50EX645 Six Blink

This set just quit working. No Flash, no noise, no warning signs. Three years old. Here are pictures of whole set and each respective board. Green LED will come on with both remote and push button, but after 30 seconds goes off and Red LED goes back to six blinks. No back light from what I can see. Any suggestions on points to test voltage or otherwise are greatly appreciated.
Attached Images
File Type: jpg KDL50EX645.jpg (384.6 KB, 84 views)
File Type: jpg SMPS.jpg (407.9 KB, 76 views)
File Type: jpg Main.jpg (448.1 KB, 43 views)
File Type: jpg Inverter.jpg (243.8 KB, 41 views)
File Type: jpg TCon.jpg (270.1 KB, 34 views)
ljintexas is offline   Reply With Quote
Old 05-16-2015, 12:43 PM   #2
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

Better Picture of SMPS
Attached Images
File Type: jpg [email protected] (443.0 KB, 68 views)
ljintexas is offline   Reply With Quote
Old 05-16-2015, 01:28 PM   #3
Hamie
Badcaps Veteran
 
Hamie's Avatar
 
Join Date: Apr 2014
City & State: Blighty
My Country: UK
I'm a: Forum Junkie
Posts: 1,368
Default Re: Sony KDL50EX645 Six Blink

Is your TV connected to the Internet?
Hamie is offline   Reply With Quote
Old 05-16-2015, 01:43 PM   #4
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

Not at the moment.
ljintexas is offline   Reply With Quote
Old 05-16-2015, 01:44 PM   #5
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

It has no backlight..no display
ljintexas is offline   Reply With Quote
Old 05-16-2015, 01:48 PM   #6
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

From what I understand, i cannot do the firmware update unless the display is working.
ljintexas is offline   Reply With Quote
Old 05-16-2015, 01:50 PM   #7
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

I have the file from Sony support
ljintexas is offline   Reply With Quote
Old 05-16-2015, 02:09 PM   #8
Hamie
Badcaps Veteran
 
Hamie's Avatar
 
Join Date: Apr 2014
City & State: Blighty
My Country: UK
I'm a: Forum Junkie
Posts: 1,368
Default Re: Sony KDL50EX645 Six Blink

Yeah it, i know that sony updated some of their range recently and it corrupted the TV. But this wouldn't have applied to you if it wasn't connected to the net.
Hamie is offline   Reply With Quote
Old 05-16-2015, 02:40 PM   #9
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

It may have been connected. I bought it as a dead set. Customer had called Sony and they told him it sounded like the SMPS..where is info about the possible corruption?
ljintexas is offline   Reply With Quote
Old 05-16-2015, 02:44 PM   #10
Hamie
Badcaps Veteran
 
Hamie's Avatar
 
Join Date: Apr 2014
City & State: Blighty
My Country: UK
I'm a: Forum Junkie
Posts: 1,368
Default Re: Sony KDL50EX645 Six Blink

info came from my local Sony centre.
Hamie is offline   Reply With Quote
Old 05-17-2015, 05:16 AM   #11
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

Reset code using 10 sec on..unplug for 15 sec..plug in and turn on using PB switch..Solid green then three green blinks for about 30 seconds...then back to six blinks. Measured pins labeled UNREG 24 Volts leading to inverter when light is green..only getting 1.59 volts. Tried this with inverter plugged in and unplugged..same result so I am reasonably sure the inverter is not dragging it down. I read on a forum that there is a known design defect in the 24 volt transformer section of this board.
ljintexas is offline   Reply With Quote
Old 05-17-2015, 05:37 AM   #12
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,373
Default Re: Sony KDL50EX645 Six Blink

Did you verify the main board is sending a power on command? The 24V will measure low if the main board does not send that command.
__________________
Please do not PM me with questions! Questions via PM will not be answered. Post on the forums instead!
Free service manuals: http://www.toms-service-manuals.com/ -- 72 LED/LCD TVs, 5 monitors, 28 plasma TVs, and 2 AVR 6.1 amplifiers fixed! -- I repair Pioneer 9G Plasma Main Boards & KRP-M01 Media Receivers (PM me for info)

2 Pioneer KURO 9G, 12 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 5 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 11 LG LCD/Plasma, 18 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 1 Baird (China) LCD, 6 Bush LCDs, 22 Vestel LCDs (Best->Worst)
tom66 is offline   Reply With Quote
Old 05-17-2015, 06:24 AM   #13
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

I did not do that Tom. Let me see if I can figure out which terminal gets the "on" command. I will check it!

Thanks!
ljintexas is offline   Reply With Quote
Old 05-17-2015, 07:00 AM   #14
nicholas1110
Senior Member
 
Join Date: Aug 2012
City & State: minnesota
My Country: usa
I'm a: Knowledge Seeker
Posts: 111
Default Re: Sony KDL50EX645 Six Blink

Hello,

I had one of these come through my shop recently. The issue was a smd resistor on the back side of the power supply. I'll look through my notes later today to find the exact location. Otherwise there is a repair service on eBay for this issue as well.
nicholas1110 is offline   Reply With Quote
Old 05-17-2015, 07:23 AM   #15
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

I verified that I have 3.3V SB, 3.3V @ POWER_ON, 12V on the two pins labeled REG12V, and [email protected]
This is for the 20 sec or so before it defaults back to six blinks with green LED on. Then all goes to 0V.
Attached Images
File Type: jpg SMPSCN2.jpg (396.5 KB, 70 views)
ljintexas is offline   Reply With Quote
Old 05-17-2015, 07:25 AM   #16
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

Thank You nicholas! Yes I saw it they say they burn it in an actual set for 12hours after repairs..Includes shipping both ways for a mere $85. They say they also know of a design defect in the board and remedy it.
ljintexas is offline   Reply With Quote
Old 05-17-2015, 02:17 PM   #17
nicholas1110
Senior Member
 
Join Date: Aug 2012
City & State: minnesota
My Country: usa
I'm a: Knowledge Seeker
Posts: 111
Default Re: Sony KDL50EX645 Six Blink

Hi, just looked through my notes. I replaced smd resistor r602d on the backside of the power su
nicholas1110 is offline   Reply With Quote
Old 05-17-2015, 02:18 PM   #18
nicholas1110
Senior Member
 
Join Date: Aug 2012
City & State: minnesota
My Country: usa
I'm a: Knowledge Seeker
Posts: 111
Default Re: Sony KDL50EX645 Six Blink

Also it read open when tested fyi
nicholas1110 is offline   Reply With Quote
Old 05-17-2015, 10:31 PM   #19
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,102
Default Re: Sony KDL50EX645 Six Blink

r602d is part of the series sensing resistors (A~D, sensing the Boosted PFC Voltage(>360vdc)), very high resistance resistors feeding IC601.
http://assets.shopjimmy.com/media/ca...-11-bottom.jpg

http://www.shopjimmy.com/sony-1-895-...e50-board.htm#
Attached Images
File Type: jpg shopjimmy-1-895-316-11-bottom.jpg (1.60 MB, 125 views)
File Type: jpg shopjimmy-1-895-316-11-top.jpg (1.25 MB, 87 views)
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809

Last edited by budm; 05-17-2015 at 10:33 PM..
budm is offline   Reply With Quote
Old 05-25-2015, 09:11 AM   #20
ljintexas
LJinTexas
 
Join Date: Jan 2015
City & State: San Antonio, Tx
My Country: USA
Line Voltage: 120/240
I'm a: Hobbyist Tech
Posts: 555
Default Re: Sony KDL50EX645 Six Blink

Just got repaired smps back from Sony service agent. They charged me $85 including Priority Mail return shipping. After close inspection here is what I found that was done:

Replaced R602 A-D
Replaced IC601
Replaced IC303
Replaced D305
Replaced ZD306

Works like a champ.

Thanks
LJ

Last edited by ljintexas; 05-25-2015 at 09:12 AM..
ljintexas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:59 PM.
Did you find this forum helpful?