Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-30-2020, 06:01 PM   #1
spleenharvester
Badcaps Veteran
 
spleenharvester's Avatar
 
Join Date: Mar 2010
City & State: UK
My Country: UK
I'm a: Hobbyist Tech
Posts: 710
Default Acer GR235H partially losing backlight

Unfortunately my trusty GR235H seems to be on its way out. After a while I lose two backlight segments at the bottom of the screen, always the same two. If I switch it off and on again it will work and keep working for hours.

A couple of times it's also been completely black screen with just the power light (I haven't shone a light on it yet to see if it's actually displaying anything), and again has started working properly after turning off and on.

What kind of problem am I dealing with here? If it's an LED strip how do I go about replacing it?
__________________
Dell E5500 | P8700 2.53GHz 3MB | GS45 GMA4500MHD | 4GB DDR2 | 64GB Crucial M4
spleenharvester is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:56 AM.
Did you find this forum helpful?