Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-29-2020, 09:38 AM   #1
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default HP 850 G2 dead no led no fan

Hy, this laptop no longer gives signs of life, pressing the button does not light the leds or the fan. the jack is intact and there is 19v on the first components.
A part number HP is SPS 799513-001 it's a Intel I7
Fabbrone is offline   Reply With Quote
Old 06-29-2020, 01:07 PM   #2
peste
Badcaps Veteran
 
Join Date: Dec 2016
City & State: CAMPINA
My Country: ROMANIA
I'm a: Knowledge Seeker
Posts: 1,655
Default Re: HP 850 G2 dead no led no fan

you have 3.3v, but 5v..you have voltage on the bios chip .. give more details.
peste is offline   Reply With Quote
Old 06-30-2020, 02:17 AM   #3
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default Re: HP 850 G2 dead no led no fan

there is no voltage on the bios chip or spi, on the battery there is 1.2V while on some components there are 1.5v
Fabbrone is offline   Reply With Quote
Old 06-30-2020, 05:54 AM   #4
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 324
Default Re: HP 850 G2 dead no led no fan

Quote:
Originally Posted by Fabbrone View Post
Hy, this laptop no longer gives signs of life, pressing the button does not light the leds or the fan. the jack is intact and there is 19v on the first components.
A part number HP is SPS 799513-001 it's a Intel I7
when you connect the power adapter do you see light that the battery is charging.. any details how it all began do you own this laptop .. and what are your actions.. do you re seat the ram connect external monitor..before you dismantle it....check for ALW voltage 3.3v 5.0. check the cmos battery if still in 3v range.
__________________
Never stop LEARNING because life never stops TEACHING!

Last edited by Duranitron; 06-30-2020 at 05:59 AM..
Duranitron is offline   Reply With Quote
Old 06-30-2020, 08:35 AM   #5
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default Re: HP 850 G2 dead no led no fan

I don't have the diagrams, the battery is not charged and no LED lights up. every now and then I connect an external video. normal use
Fabbrone is offline   Reply With Quote
Old 07-03-2020, 07:29 AM   #6
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 324
Default Re: HP 850 G2 dead no led no fan

disconnect the battery and try to start the unit using the adapter...check all the coils for voltages.. and post it here...bios ic must have a 3v vcc to function correctly.. check also the rtc bios battery.. disconnect the ram then power on,,
Duranitron is offline   Reply With Quote
Old 07-03-2020, 07:33 AM   #7
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 324
Default Re: HP 850 G2 dead no led no fan

if you cant see voltage in the coils try to look for short circuit to ground..check the 19 power rail..3.3v alw and 5v alw.. those voltages must be present to power on the unit..
Duranitron is offline   Reply With Quote
Old 07-03-2020, 07:45 AM   #8
SMDFlea
Moderator
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 4,622
Default Re: HP 850 G2 dead no led no fan

Quote:
Originally Posted by Fabbrone View Post
I don't have the diagrams, the battery is not charged and no LED lights up. every now and then I connect an external video. normal use
Check the long part number on the board,if its 6050A2637901-MB-A02 then here`s the schematic

https://www.badcaps.net/forum/showthread.php?t=85724
SMDFlea is online now   Reply With Quote
Old 07-03-2020, 07:55 AM   #9
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 324
Default Re: HP 850 G2 dead no led no fan

Quote:
Originally Posted by SMDFlea View Post
Check the long part number on the board,if its 6050A2637901-MB-A02 then here`s the schematic

https://www.badcaps.net/forum/showthread.php?t=85724
thanks,,
Duranitron is offline   Reply With Quote
Old 07-04-2020, 03:08 PM   #10
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default Re: HP 850 G2 dead no led no fan

Grazie
Fabbrone is offline   Reply With Quote
Old 07-06-2020, 08:55 AM   #11
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default Re: HP 850 G2 dead no led no fan

The plate code is that, there is a short on the L6150 5V coil
Fabbrone is offline   Reply With Quote
Old 07-07-2020, 04:39 AM   #12
Duranitron
Badcaps Veteran
 
Duranitron's Avatar
 
Join Date: Jul 2014
City & State: Caloocan, Manila
My Country: Philippines
Line Voltage: 220VAC 60hz
I'm a: Professional Tech
Posts: 324
Default Re: HP 850 G2 dead no led no fan

try to check mosfets connected to this coil..
Duranitron is offline   Reply With Quote
Old 07-13-2020, 09:12 AM   #13
Fabbrone
Senior Member
 
Join Date: Jun 2015
City & State: turin
My Country: italy
I'm a: Knowledge Seeker
Posts: 106
Default Re: HP 850 G2 dead no led no fan

there are inconsistencies between the diagram and the mainboard do not match the components
Fabbrone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:01 AM.
Did you find this forum helpful?