Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Tablets, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-14-2021, 07:30 PM   #1
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Macbook A1286 not charging no power from bat BUT WORKS ON AC

Hello

Anyone can help me out this rare issue ... macbook a1286 2010.... it is 820 2850
Works fine from ac power and disconnecting AC also works from battery no issues

But

It will not power on from bat ony
No amber lednonly green
Power on only with magsafe attached

Rest is Normal
Pd: replaced u7000 but does the same.

Thanks for any clue!

Last edited by marce002; 09-14-2021 at 07:40 PM..
marce002 is offline   Reply With Quote
Old 09-14-2021, 08:34 PM   #2
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 1,208
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

hi.

1) with battery only connected - what is the voltage of PPBUS_G3H ?

2) power down & remove all power (adapter & battery not connected); meter in resistance mode (200 ohms).

Check for shorted mosfets @ Q7055; Q7080; Q7085; Q7030; Q7035.

For each, check the resistance between

SOURCE & DRAIN
SOURCE & GATE
GATE & DRAIN
mon2 is offline   Reply With Quote
Old 09-17-2021, 10:18 AM   #3
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

thanks mon2 i will post them, but i want to add a little strange thing, which is that

in "cold overnight start" i have no power, but when I warm it up a little bit around resistor (R6995) it will just start fine.... also if put finger on R6995 it just turns off

something weird arround that zone, I thought was the GPU but it is exactly at R6995 and removed and it is fine 1Mohm.... maybe is the IC but the effect is on that Resistor...

if the mother was warm becasue left working some time, it will power on fine..... but after several hours it will not.

like some temperature issue, but related to that r6995,,,,, any hint?

thanks in advance
marce002 is offline   Reply With Quote
Old 09-17-2021, 05:48 PM   #4
reformatt
Member
 
Join Date: Feb 2020
City & State: Noosaville
My Country: Australia
I'm a: Knowledge Seeker
Posts: 28
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

Check those FET's, particularly Q7055. With no magsafe, you should get battery voltage on the input of U6990. Troubleshoot that circuit if you have no PP3V42_G3H. This area is right on the edge of the board and usually corroded.
reformatt is offline   Reply With Quote
Old 09-20-2021, 11:56 AM   #5
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

yes I have U6990 with bat volt at pin 3 BUT ALSO in pin 2?? and should be 3.42v i think... you are right seems to be NOT 3.42v in that pin 2....
clean and no corrosion zone.
volts at U6990 are (with no ac and bat connected only):

is this wrong?

1- 1.20v
2- 10.97v
3- 10.97v
4- 0v
5- 0v

6- 1.05v
7- 2.08v
8- 1.053v
9- 0.054v
10- 0.448v


Q7055 seems to be fine.

Note: battery state is unknown but each cell is at 3.98V and if i remove AC laptop continues with fans turning but removes screen image..
And i repeat, that the mac works almost fine except that CPU is slow, (fans normal speed though), and of course main issue
is that it Works fine from ac power and disconnecting AC also works from battery no issues

But

It will not power on from bat ony
No amber lednonly green
Power on only with magsafe attached

Last edited by marce002; 09-20-2021 at 12:15 PM..
marce002 is offline   Reply With Quote
Old 09-20-2021, 07:52 PM   #6
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 1,208
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

hi.

1) your DCIN voltage is too low. It should be much higher than the posted 10.x volts.

2) post the voltage @ pins 1 & 2 of J6900. Do you see the same low voltage ?

If yes, power down -> remove adapter & battery power.

Meter in resistance mode. Check the resistance to ground on F6905.

Value in ohms ?

This logic board either has a short on the same PPDCIN_G3H rail or your external power adapter is not working properly.

As a suggestion, if the voltage @ F6905 is still low, desolder this fuse so that you can confirm that the adapter voltage is capable of powering this logic board.

If indeed, the adapter voltage is 15-20V (without the fuse completing the circuit), then proceed to review all parts that are connected to this rail. Leave the fuse out so that you can study the condition of downstream parts like mosfet Q7080, etc.
mon2 is offline   Reply With Quote
Old 09-21-2021, 06:57 AM   #7
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

Hi Mon2

1) it was not DCIN, it was battery only (since i was told above to measure with no magsafe by reformatt)

2) volt with ac and bat the same:
1- 18.11v
2- 18.11v

39kohm fuse is ok f6905

power adapter is fine, it is my bench unit t and magsafe 1 cable as always.

when power on volt in fuse is 18.17v steady

the problem is NO AMBER LED ON MAGSAFE no charging, and not powering on from bat only!

Last edited by marce002; 09-21-2021 at 07:05 AM..
marce002 is offline   Reply With Quote
Old 09-21-2021, 07:40 AM   #8
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 1,208
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

Magsafe led is a single wire communication using Dallas semiconductor interface that is powered from +3v42.

Can you confirm this power rail is stable at 3v42?

That is the first requirement.
mon2 is offline   Reply With Quote
Old 09-21-2021, 07:46 AM   #9
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

yes in the coil hgave 3.38V steady but sometimes does not start, and when touching coil L6995 zone it starts, some weird behaviour is in that U6990 zone...
anyway now that is powered on it is steady at 3.38vol (just now no battery, with AC only)

attached battery and AC and remains steady at 3.38vol too

only battery also it is 3.38v

Last edited by marce002; 09-21-2021 at 07:49 AM..
marce002 is offline   Reply With Quote
Old 09-21-2021, 12:28 PM   #10
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 1,208
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

In my opnion, you should see +3v42 @ L6995, pin # 2. Perhaps others can supply their feedback on this rail or check Louis' youtube videos on the topic.

Based on the touching of L6995, consider to flux and reflow the inductor and also U6990. Do so with care so that parts are not flying around - low air pressure but with higher heat (400-500C) should be ok due to the multilayer PCBs used by the factory. Perhaps you have some corrosion causing this fault.

After the reflow, check the voltage again to see if the value is closer to +3v42 - keep in mind this is a low current rail and the feedback resistors (Ra & Rb) for the power supply IC @ U6990 have been selected to yield this output voltage.

Next, remove all power (adapter & battery) - meter in resistance mode -> check the resistance to ground on L6995, pin # 2. What is the reading ? Perhaps you have some excessive load causing this small voltage drop.

Last comment - is your meter accurate for this measurement? Maybe you can test with another meter as well to confirm ?
mon2 is offline   Reply With Quote
Old 10-13-2021, 11:51 AM   #11
marce002
Senior Member
 
Join Date: May 2018
City & State: martinez
My Country: Argentina
I'm a: Knowledge Seeker
Posts: 134
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

ok updated status is: Replaced big Resistor R6995 1004 in the 3.42v generation zone, wich despite its value reading with MM was ok, it did the trick, and now overnight or "cold"/warm issue is gone and turns on as expected butt.... still no battery charge no amber led BUT works on battery only and also plugged in with battery...in the scope smbus CLK line is always HIGH (no "movement" is freeze high) but smbus SDA line has some activity... what can be wrong... (remember macbook start and boots fine, works on bat only , works with both AC and BAT only issue IT DOES NOT charge
marce002 is offline   Reply With Quote
Old 10-13-2021, 12:16 PM   #12
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 1,208
Default Re: Macbook A1286 not charging no power from bat BUT WORKS ON AC

Good to hear that you are making some progress.

Is the battery a known good battery? Most of the time, the battery is the fault.

If you are confident that the same battery is able to charge on another box then can continue the investigation.
mon2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 11:52 AM.
Did you find this forum helpful?