Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-15-2014, 09:12 PM   #1
PlumBum
New Member
 
Join Date: Nov 2014
City & State: Torshavn
My Country: Faroe Islands
I'm a: Knowledge Seeker
Posts: 3
Default Dell 2407 wfpb no backlight

Hi i got an Dell 2407 and the backlight stopped working while i was watching a movie.
The power light and input nr is on, but no backlight.
i have opened the monitor and checked the power board an i seams fine, have also checked most of the voltages and they are fine.
The fuse F1 on the inverter board is blown, and i get 19 volt on the one side comming from the connector,
so the question is what caused the F1 fuse to blow ?
I have checked all the diodes, the three big 2.5A fuses and most of the transistors, they all seams ok.
do you have any suggestions about what caused the fuse to blow, maby the 5V voltage regulstor
Attached Images
File Type: jpg Inverter_F1.JPG (386.9 KB, 26 views)
PlumBum is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:40 PM.
Did you find this forum helpful?