Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > General Electronics Technical Discussion
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-20-2021, 03:16 AM   #1
akc1956
New Member
 
Join Date: Nov 2021
City & State: Sakon Nakhon
My Country: Thailand
Line Voltage: 220VAC 50Hz
I'm a: Hobbyist Tech
Posts: 9
Default Mosfets for P600W24V Smps

Hi, I have a 24v 600w SMPS from a cnc/engraver machine. It has stopped working, No power from the supply. I opened it up and found the main rectifier, 2 mosfets, and 2 current sence resisters all blown. I can find the bridge rectifier and resistors but not the mosfets. They have the number 600R160 on them but i searched everywhere on internet but unable to find any datasheet or info to get equivalent. The only reference I can find to 600R160 is for resetable fuses. Can anyone advise me as to what a replacement might be. I have attached photos if its any help. Thanks in advance for any info.
Attached Images
File Type: jpg IMG_20210916_184803.jpg (1.36 MB, 23 views)
File Type: jpg IMG_20210916_193004.jpg (408.3 KB, 14 views)
File Type: jpg IMG_20210916_190617.jpg (271.3 KB, 16 views)

Last edited by SMDFlea; 11-20-2021 at 06:53 AM.. Reason: P600W24V
akc1956 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:20 PM.
Did you find this forum helpful?