Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-26-2019, 02:36 AM   #1
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Help required with DEll 2209WA monitor

Hi Folks

Facing a weird problem with my monitor. I have attached two images. When i switch on the monitor i see image 1 as shown in image 1

Now if i leave the monitor on for about 15 minutes it becomes proper as shown in image 2 as shown .

Is this a repairable issue or is the panel dying. I opened up the monitor thinking there were some bad caps causing this issue, but could not find any damaged/leaking caps. The monitor is about 8 years old. Any ideas ?
Attached Images
File Type: jpg Image1.jpg (39.2 KB, 33 views)
File Type: jpg Image2.jpg (34.6 KB, 33 views)
jinu_j is offline   Reply With Quote
Old 10-27-2019, 12:13 AM   #2
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Re: Help required with DEll 2209WA monitor

Posting some more pictures of the main boards

Main Board


Side board


I cant see anything burnt or damaged. So what is possibly causing this behaviour.
Attached Images
File Type: jpg Main Board.JPG (460.5 KB, 26 views)
File Type: jpg Sigboard.jpg (450.0 KB, 25 views)
jinu_j is offline   Reply With Quote
Old 10-27-2019, 06:44 AM   #3
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Re: Help required with DEll 2209WA monitor

Adding the image of the TCON Board. Again no damage visible.

Attached Images
File Type: jpg TCON.jpg (369.2 KB, 24 views)
jinu_j is offline   Reply With Quote
Old 10-27-2019, 02:48 PM   #4
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 4,875
Default Re: Help required with DEll 2209WA monitor

Try reseating the plug connections on the t-con board and see if that helps. You cam also use a heat source like a hair dryer and heat sections of the tcon or main board to see if you can speed up the return to normal picture. The power supply section and the inverter board are not likely the cause of the problem. but the fault could be on the lcd panel board itself (CN2 cable connects to panel board)

Last edited by R_J; 10-27-2019 at 02:50 PM..
R_J is offline   Reply With Quote
Old 10-30-2019, 12:26 PM   #5
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Re: Help required with DEll 2209WA monitor

Thanks for the response. I tried reseating the plug connection on the TCON board. Also heated the the TCON board using a heat gun, but made no difference. So guess the panel board is failing and that cannot be changed or modified.
jinu_j is offline   Reply With Quote
Old 10-30-2019, 01:27 PM   #6
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 21,571
Default Re: Help required with DEll 2209WA monitor

your probem may be caps on the main board - i had a tv do similar shit because of caps around the main chip
stj is offline   Reply With Quote
Old 11-02-2019, 08:56 PM   #7
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Re: Help required with DEll 2209WA monitor

Wierd behaviour I put everything back together and now the i have a new set of problems. Now when i on the Monitor, no issues at all just some faint horizontal line, but image is clear and usable. But after about 1 hours of continuous usage the monitor goes back to the old problem and becomes unusable. I switch off the monitor for about 10 minutes and the monitor clears up again.

Another new problem is a crackling/hissing sound coming from the monitor right hand side. This hissing sound comes only if there is an image on the screen. if the screen is blank then no sound.

Another problem i have observed is the time taken for the power light to go off once i off the main power switch at the electrical outlet connecting the monitor. It takes alteast 10-15 secs for the power light to go off.
jinu_j is offline   Reply With Quote
Old 11-03-2019, 03:27 AM   #8
jinu_j
Member
 
Join Date: Feb 2016
City & State: Mumbai
My Country: India
I'm a: Knowledge Seeker
Posts: 24
Default Re: Help required with DEll 2209WA monitor

Ok figured out the problem with the hissing/crackling sound. one of the connectors to the backlight is burnt to crisp. so much so that the rubber padding that was holding it is completely burnt. Not sure why this happened.

See image



Question i have is can i directly solder the backlight tube terminal to the backlight connector on the PCB ?
Attached Images
File Type: jpg Burnt.jpg (876.3 KB, 9 views)
jinu_j is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:23 AM.
Did you find this forum helpful?