Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Game Consoles & Other Weird Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-12-2021, 02:42 PM   #20
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 8,099
Default Re: Motor control board repair

Quote:
Originally Posted by cyclones View Post
It looks like the -15V goes back to SR3 and the voltage regulator that doesn't get warm, AVR2. From looking at the trace lines and from the meter, it seems like the AVR2 is in parallel. SR3 has a + and - and two middle pins that go to the AC input, so it seems like a rectifier bridge, but I don't know what the SR3 designation could mean. Any ideas?
Are you getting a/c voltage to SR3? It is likely a bridge rectifier, why it is labeled SR3, who knows.
If you are not getting any a/c to the bridge, check the resistance of the traces and the power supply winding that supplies that circuit.
What is the part number on SR3?
R_J is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:50 AM.
Did you find this forum helpful?