Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 04-15-2022, 11:20 PM   #1
RukyCon
A Fake Rubycon
 
RukyCon's Avatar
 
Join Date: Jan 2017
City & State: Peoples Republic of California
My Country: USA
Line Voltage: 122.5VAC 59.9Hz
I'm a: Knowledge Seeker
Posts: 673
Default ZUMAX Technology (Leadman Power) ZU400W (X1), Modifications & Life Test

Hello Again, so i'm bringing back this Zumax PSU from the gutless thread and going to be doing some modifications, and also putting it into a PC i'm going to throw together out of spare parts to see how long it lasts.

So the first thing i did was fill in the missing filtering, by replacing the cheap common mode choke with a real one and adding a 470nf X2 capacitor in the open capacitor spot, i then replaced the fake Y-class capacitors with real ones, i also swapped out the mismatched primary caps with a pair of Aishi WK 470uf 200v caps, both of which test around 520uf. I also swapped out the two smaller electrolytics with the following:
Old Parts: Chang CD110 47uf 50v, Chang 4.7uf 50v.
Replacements: Ymin LKM 39uf 50v, Topazcon LJ 4.7uf 50v.
Now, whether these new caps will be better than the old ones remains to be seen, but it will be interesting to see how they might age.

Now onto the secondary, I swapped out the SBL3040PT rectifier on the 5VSB rail with a SB560, i also tested the SBL3040PT and found that indeed, one half of it was shorted.

I added the missing PI coils on the 5v and 12v rails, as well as swapped out most of the secondary caps with the following:

5VSB - 2x Cheng LOWESR 470uf 16v ⇒ 2x Topazcon LF 1000uf 10v.
12v - Cheng LOWESR 1500uf 25v ⇒ Ymin LKM 2700uf 16v + Capxon GF 1500uf 16v.
5v - Cheng LOWESR 2200uf 10v ⇒ Ymin LKM 2700uf 16v + Topazcon LF 1200uf 16v.
3.3v - Cheng LOWESR 470uf 10v ⇒ Chengx GR 2200uf 16v.
-12v - Cheng LOWESR 470uf 16v ⇒ Ymin LKM 680uf 25v.

So now that was done, it was time to test the PSU, so i got it all back together, plugged it in, and... Nothing.

Well that's not fully true, the 5VSB did come on, but everything else was still dark, but the main fan did twitch, which suggests that the main PSU did try to come on, but something was stopping it. So now it was time to troubleshoot, and my first though on what to check was the secondary capacitors. So i first try removing the 2700uf cap on the 12v rail, and that did nothing, so i try the same thing with the 2700uf cap on the 5v rail, and bingo, the power supply came to life. And it would still come on even after putting the 12v rail capacitor back in place. So after a bit of poking around and swapping the 5v rail capacitors around until i decided to go with a Chengx GR 2200uf 16v + Capxon GF 1500uf 16v caps for the 5v rail, since the PSU would still start with these in place.

So now the power supply is "repaired", the next part of this adventure will be throwing together the rig that this thing will run, and then counting how many days this thing runs before either the switching, or the smoothing part of the PSU gives out, but that will (hopefully) be tomorrow.
Attached Images
File Type: jpg IMG_20220415_173218[1].jpg (519.7 KB, 8 views)
File Type: jpg IMG_20220415_161731[1].jpg (568.7 KB, 8 views)
File Type: jpg IMG_20220415_161706[1].jpg (584.8 KB, 8 views)
File Type: jpg IMG_20220415_161658[1].jpg (548.8 KB, 8 views)
RukyCon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:38 AM.
Did you find this forum helpful?