Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-03-2021, 03:10 PM   #1
grimacelord
Senior Member
 
Join Date: Jan 2017
City & State: Atlanta, GA
My Country: USA
I'm a: Knowledge Seeker
Posts: 145
Default Samsung UN50MU6070FXZA - HDMI Ports Not Working

Hello. Samsung UN50MU6070FXZA here with both HDMI ports non-working. I have already verified multiple sources and multiple cables to ensure it isn't something simple like that as well as resets and software updates.

I took the mainboard out and gave it a look. Nothing looks bad or burned. All of the HDMI pins are nice, none are broken at their pads either.

Following the traces, it looks like both HDMI ports trace back to the main CPU which does seem to get hotter than I think it should despite it's (rather poor) heatsink.

Since the HDMI controller appears to be integrated within the CPU, is the CPU the culprit? The TV turns on just fine and everything seems to work ok except for these two HDMI ports.

Just going off of past experience, it almost SEEMS like the CPU got too hot after the life of the TV due to the shoddy heatsink installed by Samsung. One or more of the BGA balls under the chip is damaged from the heating/cooling over and over and while it turns on ok, no HDMI. Does this sound like a reasonable theory?

If I am right, wouldn't a reflow/reball potentially fix this issue? I don't want to reflow/reball it if I don't have to because like I said, the TV still works fine otherwise.

I'm attaching some pics. Let me know what you guys think. Thanks.
Attached Images
File Type: jpg PXL_20211103_170131429.jpg (1,022.1 KB, 15 views)
File Type: jpg PXL_20211103_170143222.jpg (706.7 KB, 8 views)
File Type: jpg PXL_20211103_170157779.jpg (932.9 KB, 14 views)
grimacelord is offline   Reply With Quote
Old 11-04-2021, 03:35 AM   #2
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,087
Default Re: Samsung UN50MU6070FXZA - HDMI Ports Not Working

it could be a cracked ball/s, it could also be the HDMI part of the chip damaged possibly due to hot swapping. You could try a bit of heat on the processor to see if it temporarily gives a picture.
diif is online now   Reply With Quote
Old 11-04-2021, 03:52 AM   #3
ducky29
Badcaps Veteran
 
Join Date: Dec 2015
City & State: -
My Country: Europe
I'm a: Professional Tech
Posts: 332
Default Re: Samsung UN50MU6070FXZA - HDMI Ports Not Working

The cpu on these models gets extremly hot but I think that the large heatsink does the job properly. I have already taken a look a dozen of these, all have very hot cpus even when the board is not faulty. Do a factory reset and then look for a board replacement.
ducky29 is offline   Reply With Quote
Old 11-04-2021, 07:19 AM   #4
lotas
Badcaps Veteran
 
Join Date: Jan 2016
City & State: Sochi
My Country: russia
I'm a: Knowledge Seeker
Posts: 856
Default Re: Samsung UN50MU6070FXZA - HDMI Ports Not Working

Ring a multimeter between the signal lines and GND and there is 5v on 18 pin.
Attached Images
File Type: jpg hdmi.jpg (109.5 KB, 12 views)
File Type: png HDMI Pin.PNG (241.0 KB, 15 views)
lotas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 05:17 AM.
Did you find this forum helpful?