Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-18-2022, 09:58 AM   #1
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Sony KD-55X8509C fails after warmup

Hi, I've got a Sony set that acts weird. It works absolutely fine for 2-3 hours, then shuts down with 6 blinks. After a bit of cooldown it works again for some time. Service menu indicates backlight error, but in edge-lit TV it would be clearly visible that one or more LEDs fail.
The person I bought the TV from replaced the power supply with no effect on the issue (he even gave me.the spare one with the TV). Main board and the TCon seem reasobably warm.
Pics of PSU (original one) and MB attached.
Attached Images
File Type: jpg 16528894199772842274423116027685.jpg (683.2 KB, 10 views)
File Type: jpg 16528894400156440968753206944924.jpg (527.5 KB, 12 views)
mrsith is offline   Reply With Quote
Old 05-18-2022, 10:15 AM   #2
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,196
Default Re: Sony KD-55X8509C fails after warmup

need a picture of the whole back of tv as to see how everything is connected.
nomoresonys is offline   Reply With Quote
Old 05-18-2022, 10:41 AM   #3
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,817
Default Re: Sony KD-55X8509C fails after warmup

I would heat parts of main board and see if you can locate problem.
__________________
I assume no responsibility for any stupid suggestions I might post.
dskall is offline   Reply With Quote
Old 05-18-2022, 11:16 AM   #4
kasfamily
Badcaps Veteran
 
kasfamily's Avatar
 
Join Date: Aug 2014
City & State: Vologda
My Country: Russia
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 483
Default Re: Sony KD-55X8509C fails after warmup

https://youtu.be/uW3i_rSSwjk
kasfamily is offline   Reply With Quote
Old 05-18-2022, 12:09 PM   #5
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Re: Sony KD-55X8509C fails after warmup

Pic attached showing how everything is connected.

I'll try heating.

I know how to replace the backlights, it doesn't seem like a LED strip problem as they work fine for couple of hours before the TV fails.
Attached Images
File Type: jpg 16528969638568255946192552043590.jpg (488.6 KB, 10 views)
File Type: jpg 16528972806455739593811056261993.jpg (520.8 KB, 11 views)
mrsith is offline   Reply With Quote
Old 05-18-2022, 12:24 PM   #6
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,196
Default Re: Sony KD-55X8509C fails after warmup

ok, have a good look the legend/map on powerboard, do any of them say bl-err?
nomoresonys is offline   Reply With Quote
Old 05-18-2022, 02:11 PM   #7
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Re: Sony KD-55X8509C fails after warmup

BL-ERR gives 2.3v with set powered off but plugged in.
mrsith is offline   Reply With Quote
Old 05-18-2022, 03:13 PM   #8
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,196
Default Re: Sony KD-55X8509C fails after warmup

what does it read powered up?
nomoresonys is offline   Reply With Quote
Old 05-19-2022, 05:32 PM   #9
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Re: Sony KD-55X8509C fails after warmup

Nothing at all.

I've been told by 2 separate sources that the smthe LEDs tend to fail this way in this TVs. Been explained how and why and it made sense so I've boufmght replacement strips. I'll post if it solved the problem after changing and testing them.
mrsith is offline   Reply With Quote
Old 05-19-2022, 06:38 PM   #10
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,196
Default Re: Sony KD-55X8509C fails after warmup

could be backlights and they do fail a lot but i have a feeling it isn't.
nomoresonys is offline   Reply With Quote
Old 05-20-2022, 12:56 PM   #11
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Re: Sony KD-55X8509C fails after warmup

Apparently these backlights tend to fail this way. I had original parts to replace and I could see that old LEDs were clearly darker/oranger than new strips.

The TV was working fine for 5-6 hours after replacing them, looks like the job is done. Thanks a lot for your attention and advice!
mrsith is offline   Reply With Quote
Old 05-20-2022, 05:11 PM   #12
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,196
Default Re: Sony KD-55X8509C fails after warmup

ok, glad to hear its fixed, so to be clear, when tv is working properly, the standby bl-err is 2.3, and 0 when powered up?
nomoresonys is offline   Reply With Quote
Old 05-21-2022, 02:46 AM   #13
kasfamily
Badcaps Veteran
 
kasfamily's Avatar
 
Join Date: Aug 2014
City & State: Vologda
My Country: Russia
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 483
Default Re: Sony KD-55X8509C fails after warmup

Recommendations
The APS-385 power supply uses two four-channel CXA3854M chips, a total of 8 channels. The outputs of the inputs FB - 19, 20, 21, 22 of each chip are supplied with a signal from current sensors consisting of three low-resistance resistors connected in parallel to a chain of transistor switches. Reduce the backlight current from 140 mA to 90 mA in each channel - remove eight 8.2 Ohm resistors in each channel.
kasfamily is offline   Reply With Quote
Old 05-21-2022, 05:33 AM   #14
mrsith
Member
 
Join Date: Mar 2021
City & State: Glasgow
My Country: Wielka Brytania
I'm a: Knowledge Seeker
Posts: 79
Default Re: Sony KD-55X8509C fails after warmup

To be honest I did not check bl-err voltage after replacing the LEDs, I'll try to do that if it's still in the office.

Great advice with resistors, thank you!
mrsith is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 11:59 PM.
Did you find this forum helpful?