Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-19-2020, 03:27 AM   #1
Xebozone
New Member
 
Join Date: Sep 2019
City & State: WA
My Country: Australia
I'm a: Knowledge Seeker
Posts: 5
Default Troubleshooting 2xFailed Cooler Master v650 PSUs

I have a couple of these PSUs that have the exact same issue on both of them. I find it odd that they both exhibit the same Symptoms.

When plugged into the PC, the PSUs are able to power the LEDs inside the motherboard (the standby 5v circuit I suppose?) But as soon as the power button is hit, the PSU powers on for a split second, then there is a (relay?) click and the PSU shuts off. Hitting power does nothing after unless the power is removed and then turned on again.

I have a PSU tester which has the same results. As soon as the tester plugs in, it powers on for a split second, and then there's the click and it's off. Turning off the power switch does nothing. If I remove and replug the 24(?)pin power cable though, it does do the click on and off.

I opened the PSU and looked inside, but cannot see any signs of failure.
I noted a relay: 307H-1AH-FC 12V=DC that I believe is making the clicks.

Any ideas of how to diagnose further?
Attached Images
File Type: jpg IMG_20200219_175822_resize_1.jpg (172.9 KB, 16 views)
File Type: jpg IMG_20200219_175819_resize_10.jpg (201.7 KB, 12 views)
File Type: jpg IMG_20200219_175829_resize_12.jpg (129.9 KB, 11 views)
File Type: jpg IMG_20200219_175826_resize_6.jpg (136.6 KB, 10 views)
File Type: jpg IMG_20200219_175857_resize_13.jpg (170.2 KB, 11 views)
File Type: jpg IMG_20200219_175836_resize_94.jpg (185.6 KB, 13 views)

Last edited by Xebozone; 02-19-2020 at 04:20 AM..
Xebozone is offline   Reply With Quote
Old 02-19-2020, 05:48 AM   #2
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 22,168
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

check the output diodes - it may be detecting a short circuit.
stj is offline   Reply With Quote
Old 02-19-2020, 08:38 AM   #3
Xebozone
New Member
 
Join Date: Sep 2019
City & State: WA
My Country: Australia
I'm a: Knowledge Seeker
Posts: 5
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

Quote:
Originally Posted by stj View Post
check the output diodes - it may be detecting a short circuit.

Thank you.
I'm new to electronics repair. Where would I locate the output diodes? There appear to be 4 or 5 diodes on the board.
Would I need to remove the diodes to test them?
Xebozone is offline   Reply With Quote
Old 02-19-2020, 12:30 PM   #4
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 22,168
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

try to take closer pictures - specially the 2 matching vertical boards
stj is offline   Reply With Quote
Old 02-20-2020, 03:56 AM   #5
Xebozone
New Member
 
Join Date: Sep 2019
City & State: WA
My Country: Australia
I'm a: Knowledge Seeker
Posts: 5
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

Thanks so much for your help.
I've attached some photos from around the board including the vertical boards (I didn't see any diodes around there though). I've taken photos of areas where I can spot a diode
Attached Images
File Type: jpg IMG_20200220_174835.jpg (614.4 KB, 11 views)
File Type: jpg IMG_20200220_174815.jpg (779.5 KB, 15 views)
File Type: jpg IMG_20200220_174800.jpg (726.2 KB, 14 views)
File Type: jpg IMG_20200220_174743.jpg (651.0 KB, 12 views)
File Type: jpg IMG_20200220_174658.jpg (614.8 KB, 12 views)
File Type: jpg IMG_20200220_174610.jpg (676.6 KB, 11 views)
File Type: jpg IMG_20200220_174546.jpg (691.5 KB, 12 views)
File Type: jpg IMG_20200220_174505.jpg (552.4 KB, 10 views)
File Type: jpg IMG_20200220_174450.jpg (655.1 KB, 10 views)
File Type: jpg IMG_20200220_174426.jpg (661.5 KB, 9 views)
File Type: jpg IMG_20200220_174350.jpg (640.2 KB, 11 views)
File Type: jpg IMG_20200220_174344.jpg (632.5 KB, 10 views)
File Type: jpg IMG_20200220_174331.jpg (710.8 KB, 10 views)
Xebozone is offline   Reply With Quote
Old 02-20-2020, 04:33 AM   #6
stj
Great Sage 齊天大聖
 
stj's Avatar
 
Join Date: Dec 2009
City & State: Europe
My Country: some shithole run by Israeli agents
I'm a: Professional Tech
Posts: 22,168
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

i think i know what they did.
check ZD6, check all the transistors bolted to heatsinks,
get the board out of the shell and see whats soldered to the other side.

i think they are using mosfets instead of diodes.
stj is offline   Reply With Quote
Old 02-26-2020, 01:17 PM   #7
snipersquad100
Badcaps Veteran
 
Join Date: Nov 2013
City & State: swansea
My Country: uk
I'm a: Knowledge Seeker
Posts: 226
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

Is it me or does this cap look suspicious?
badcap.jpg
snipersquad100 is offline   Reply With Quote
Old 02-27-2020, 01:34 PM   #8
Stefan Payne
Badcaps Veteran
 
Join Date: Dec 2009
City & State: Northern Germany
My Country: Germany
Line Voltage: 230VAC/50Hz or 400VAC/3P/50Hz
I'm a: Knowledge Seeker
Posts: 1,219
Default Re: Troubleshooting 2xFailed Cooler Master v650 PSUs

Not really...
You need to start measrunging...
Try looking for shorts.
Polymer caps fail that way for example...
Stefan Payne is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 11:16 AM.
Did you find this forum helpful?