Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-06-2020, 02:31 PM   #1
Beaknuke
New Member
 
Join Date: Jan 2019
City & State: Barnstaple
My Country: Engand
I'm a: Knowledge Seeker
Posts: 2
Default Samsung PS-507-PHN PSU / PHILLIPS 50in TV

Hi,
I been tracing thru the PSU board, in or out of the TV the symptons are the same.
The little board gives a flash code of 3 blinks which the indication of Vg.

Front of the TV gave the indication of 2 blinks (i think).

I replaced all the caps as per cap kit, quite a few visually damaged ones but measurements were not bad.

I hear relay clicks, pretty quick in shutting itself down. I been following some online videos, but so far not got there, anyone have a quick tip?

The caps with tippex/white mark on the edge are replaced.
Attached Images
File Type: jpg image0.jpg (301.9 KB, 8 views)
Beaknuke is offline   Reply With Quote
Old 06-08-2020, 04:45 AM   #2
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 5,544
Default Re: Samsung PS-507-PHN PSU / PHILLIPS 50in TV

How to test LJ92-01511A PS-507-PHN power supply


https://www.youtube.com/watch?v=D0PPC9Pi0hc
__________________
Willing to help but I'm no expert.
dick_barton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:17 AM.
Did you find this forum helpful?