Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Printers, Copiers, Scanners and other Imaging & Printing Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-20-2022, 02:17 PM   #1
aboumohamed
Member
 
Join Date: Dec 2018
City & State: alger
My Country: algeria
I'm a: Knowledge Seeker
Posts: 93
Default Canon mf3010 w'ont turn on


HELP ME IDENTIFY THE EQUIVALENT OF THE SMD MOSFET Q203 ON A CANON MF3010 POWER SUPPLY
Attached Images
File Type: jpg MA FM0-1059.jpg (850.9 KB, 22 views)
aboumohamed is offline   Reply With Quote
Old 01-21-2022, 03:24 AM   #2
SMDFlea
Super Moderator
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 10,090
Default Re: Canon mf3010 w'ont turn on

Quote:
Originally Posted by aboumohamed View Post

HELP ME IDENTIFY THE EQUIVALENT OF THE SMD MOSFET Q203 ON A CANON MF3010 POWER SUPPLY
Superman wouldn`t be able to see the marking on that. Post a better picture of it so the top marking can be seen clearly
SMDFlea is offline   Reply With Quote
Old 01-21-2022, 11:57 AM   #3
aboumohamed
Member
 
Join Date: Dec 2018
City & State: alger
My Country: algeria
I'm a: Knowledge Seeker
Posts: 93
Default Re: Canon mf3010 w'ont turn on

smd mosfet marking TR2U
aboumohamed is offline   Reply With Quote
Old 01-23-2022, 04:16 AM   #4
aboumohamed
Member
 
Join Date: Dec 2018
City & State: alger
My Country: algeria
I'm a: Knowledge Seeker
Posts: 93
Default Re: Canon mf3010 w'ont turn on

Help me identify the equivalent of the smd mosfet q203 on a canon mf3010 power supply
smd mosfet marking TR2U
Attached Images
File Type: jpg smd mosfet marking TR2U broken.jpg (47.0 KB, 12 views)
File Type: jpg MA FM0-1059.jpg (804.1 KB, 12 views)
aboumohamed is offline   Reply With Quote
Old 01-26-2022, 06:19 AM   #5
aboumohamed
Member
 
Join Date: Dec 2018
City & State: alger
My Country: algeria
I'm a: Knowledge Seeker
Posts: 93
Default Re: Canon mf3010 w'ont turn on

I have identified the q203 :marquage "TR2U" or "WY"
rsr025p03
mosfet p-ch -30v -2.5a
but i would like to know the cause of this failure. Thanks to all

Last edited by aboumohamed; 01-26-2022 at 06:36 AM..
aboumohamed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:41 PM.
Did you find this forum helpful?