Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 03-30-2022, 02:24 AM   #1
angelos
Badcaps Veteran
 
Join Date: Dec 2012
City & State: Free State
My Country: South Africa
Line Voltage: 220V AC
I'm a: Professional Tech
Posts: 352
Default Samsung Smart TV - No HDMI working

Hi guys, this is just a general question but if this TV has got 2 HDMI ports and both do not work what could be the problem.
So If I feed a signal to the HDMI1 and put my TV to that source all I get is a blank screen. I do not get a "no signal" message. If I switch off my DVD player (The source) then I get a message saying no signal.
Software is up to date (Tried updating it) - Don't know how to back roll the update.
Also I don't know what to look for in service mode that might have a bearing on this issue.

Regards
Angelos
angelos is offline   Reply With Quote
Old 03-30-2022, 04:48 AM   #2
jord4231
New Member
 
Join Date: Feb 2022
City & State: Victoria
My Country: Australia
Line Voltage: 240v
I'm a: Knowledge Seeker
Posts: 11
Default Re: Samsung Smart TV - No HDMI working

Possibly not helpful but just because I had a dvd player fail today in a very similar way have you tried a different device on the HDMI inputs? Perhaps a computer or laptop that will detect a display.
Also check the hdmi cable?

With out having a look inside the TV I once had one where the tv would show everything on the onscreen display but no HDMI inputs.
I heated the processor and the inputs came back.
jord4231 is offline   Reply With Quote
Old 03-30-2022, 09:35 AM   #3
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,809
Default Re: Samsung Smart TV - No HDMI working

Bad hdmi chip. Lack of voltage to hdmi.
__________________
I assume no responsibility for any stupid suggestions I might post.
dskall is offline   Reply With Quote
Old 03-31-2022, 01:22 AM   #4
angelos
Badcaps Veteran
 
Join Date: Dec 2012
City & State: Free State
My Country: South Africa
Line Voltage: 220V AC
I'm a: Professional Tech
Posts: 352
Default Re: Samsung Smart TV - No HDMI working

Quote:
Originally Posted by dskall View Post
Bad hdmi chip. Lack of voltage to hdmi.
I have ordered new board already. Just very expensive.
angelos is offline   Reply With Quote
Old 03-31-2022, 01:23 AM   #5
angelos
Badcaps Veteran
 
Join Date: Dec 2012
City & State: Free State
My Country: South Africa
Line Voltage: 220V AC
I'm a: Professional Tech
Posts: 352
Default Re: Samsung Smart TV - No HDMI working

Quote:
Originally Posted by jord4231 View Post
Possibly not helpful but just because I had a dvd player fail today in a very similar way have you tried a different device on the HDMI inputs? Perhaps a computer or laptop that will detect a display.
Also check the hdmi cable?

With out having a look inside the TV I once had one where the tv would show everything on the onscreen display but no HDMI inputs.
I heated the processor and the inputs came back.
I have tried different devices, no luck. But yes it would be the main board. So i will order a new one.
angelos is offline   Reply With Quote
Old 03-31-2022, 11:19 PM   #6
angelos
Badcaps Veteran
 
Join Date: Dec 2012
City & State: Free State
My Country: South Africa
Line Voltage: 220V AC
I'm a: Professional Tech
Posts: 352
Default Re: Samsung Smart TV - No HDMI working

Thanks goes to everyone who responded to help confirm my suspicions!
Regards
angelos is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 06:51 AM.
Did you find this forum helpful?