Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-07-2021, 07:47 AM   #1
JDC
Badcaps Veteran
 
Join Date: May 2015
City & State: Wheeling, WV
My Country: USA
I'm a: Hobbyist Tech
Posts: 229
Default (SOLVED) Sharp LC-46SB57UN Takes a couple to turn on and then no video.

Solution: Replace main board. I didn't in this case and ended up scrapping the TV.

This particular set is known for losing its 5V standby. There are repair kits available for this issue and a couple threads addressing that issue here in the forums. This particular issue addresses the TV taking a few tries to turn on and when it did, there was no video, and nothing lit up. I'm assuming the main board wasn't sending the signal to turn the backlights on. Power switch was tested and confirmed working.

A replacement main board on ebay is around $200, not worth it in my opinion.
JDC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:43 AM.
Did you find this forum helpful?