Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-20-2021, 05:07 PM   #1
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Help diagnosing no backlight and no picture - Wasabi Mango

Hi there, I have a rather interesting looking set of boards in this Wasabi Mango U400UHD TV (korean OEM), not much information available online.

The components inside appear to be a mismatch of OEMs - the power board comes up as an RCA part? The TCON has Samsung logos on it, and there are no real identifiers on the mainboard, which I think is a generic part?

Either way, I'm not getting any indication of life now, aside from the power LED changing colors and the startup chime. The shutoff chime seems to be gone, although the LED does change from blue to red when shutting down. I was able to get it working for a period of time previously by jiggling some cables (not sure which it was, it just magically started afterwards), but have no such luck now.

I didn't find any obvious test points or things to check on these boards - any pointers for what I should try to diagnose?
Attached Images
File Type: jpg 20210220_135753.jpg (689.6 KB, 27 views)
File Type: jpg 20210220_135812.jpg (648.6 KB, 22 views)
File Type: jpg 20210220_150442.jpg (727.1 KB, 14 views)
viewfindr is offline   Reply With Quote
Old 02-20-2021, 09:39 PM   #2
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,116
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

1) Can you show us the whole back side of the TV showing all the boards so we can see how they are connected together?

2) Remove the power supply board and see if there are pin labels for the connectors printed on the bottom side of the board.
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809
budm is offline   Reply With Quote
Old 02-20-2021, 11:43 PM   #3
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Photos attached below. Thanks for the pointer to look behind the board. I'm guessing my next step will be to test the 5V and 24V outs to see if they're high when the power is on?

There's unfortunately this plastic backing piece which is attached with pins that's rather hard to remove from the power board.
Attached Images
File Type: jpg 20210220_212234.jpg (839.4 KB, 16 views)
File Type: jpg 20210220_212745_HDR.jpg (648.3 KB, 19 views)
viewfindr is offline   Reply With Quote
Old 02-21-2021, 02:03 AM   #4
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Just took some measurements on the PSU - 5VSB line was about 5V with tv off, and measured 12.97V on the +12V line and 5.5V on the +5V line both on the bottom section and top section cables when powered up. Doesn't look like 24V pins are hooked up.
viewfindr is offline   Reply With Quote
Old 02-21-2021, 06:54 AM   #5
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 6,227
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

There's also two other signal lines which look like PON and BK/ON for which the voltages have not been given
__________________
Willing to help but I'm no expert.
dick_barton is offline   Reply With Quote
Old 02-22-2021, 07:23 AM   #6
neilc6
Badcaps Veteran
 
Join Date: Nov 2015
City & State: BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,072
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Usually if a tv turns on and off with no backlight or a flash of backlight, the backlights are suspect. A LED tester is helpful in this scenario. Also confirm the backlight on control signal is going high.

Last edited by neilc6; 02-22-2021 at 07:24 AM..
neilc6 is offline   Reply With Quote
Old 02-22-2021, 08:09 AM   #7
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 6,227
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

What's happened to the solder joint of the component above D22 as in your photo 2 - 2 in post #3
dick_barton is offline   Reply With Quote
Old 02-22-2021, 03:49 PM   #8
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,116
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Quote:
Originally Posted by dick_barton View Post
there's also two other signal lines which look like pon and bk/on for which the voltages have not been given
+1
budm is offline   Reply With Quote
Old 02-23-2021, 01:51 AM   #9
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Quote:
Originally Posted by dick_barton View Post
What's happened to the solder joint of the component above D22 as in your photo 2 - 2 in post #3
Sharp eyes! I think it's just a bit of debris - I was able to remove most of it with tweezers.

Here are the rest of the readings:

PS-ON: 3.1V
BK/ON: 5.1V
ADJ (I think, pin right above BK/ON): 4.7V

All of these measured about 20-50 mV when TV is powered off. Side note, I just noticed that the optical audio out port lights up when powered on, so it seems like unit is receiving adequate power?
viewfindr is offline   Reply With Quote
Old 02-25-2021, 11:20 PM   #10
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Any additional thoughts? Would it be possible to verify the backlight is working by shorting some of the pins on the psu directly?
viewfindr is offline   Reply With Quote
Old 02-26-2021, 03:59 AM   #11
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 6,459
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Can you post a clear picture of the label you mention on the back of the powerboard?
__________________
Signature: Any Stooge can find an "Idiot" by looking in his mirror.
nomoresonys is offline   Reply With Quote
Old 02-26-2021, 01:11 PM   #12
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Quote:
Originally Posted by nomoresonys View Post
Can you post a clear picture of the label you mention on the back of the powerboard?
There is no "label" per se, just a plastic shield behind the components on the back and where it's mounted against the metal back of the panel.

I've attached another angle of the back of the board, where it's more visible and the top pin outs are clearer. Is there anything else I should look out for?
Attached Images
File Type: jpg 20210220_212739_HDR.jpg (651.7 KB, 4 views)
viewfindr is offline   Reply With Quote
Old 02-26-2021, 01:18 PM   #13
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 6,227
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Can you press menu on the remote and look very carefully with a bright light (torch) at an angle to see if there is an image on the screen.
I suspect you have bad led(s) or led connection
dick_barton is offline   Reply With Quote
Old 02-26-2021, 11:57 PM   #14
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Quote:
Originally Posted by dick_barton View Post
Can you press menu on the remote and look very carefully with a bright light (torch) at an angle to see if there is an image on the screen.
I suspect you have bad led(s) or led connection
I think you're right - I kept clicking around in the menus to see if it was visible, and started to see text at a very precise angle - very hard to find!

Miraculously, the TV suddenly lit up while I was doing this. It seems to be working as normal now, not really sure why - nothing was really changed during this time, and connections are the same. I noticed the back panel was a little warm, so could it have needed to warm up?

Still perplexed at why.. I checked pure white and black screens, and the lighting appears to be uniform as well.
viewfindr is offline   Reply With Quote
Old 02-27-2021, 04:43 AM   #15
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 6,227
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

So it does appear to be some sort of backlight only issue. If you get it running again, turn the backlights down as far as you can while still having a visible image and see if this alters the sets behaviour.

Last edited by dick_barton; 02-27-2021 at 04:44 AM..
dick_barton is offline   Reply With Quote
Old 02-27-2021, 04:57 AM   #16
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 6,459
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Quote:
Originally Posted by dick_barton View Post
can you press menu on the remote and look very carefully with a bright light (torch) at an angle to see if there is an image on the screen.
I suspect you have bad led(s) or led connection
+10
nomoresonys is offline   Reply With Quote
Old 02-27-2021, 01:26 PM   #17
viewfindr
Member
 
Join Date: Feb 2019
City & State: San Francisco, CA
My Country: USA
I'm a: Knowledge Seeker
Posts: 37
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Yep, definitely the backlight. The set worked fine for about 5 power cycles, but now it's not lighting up again. Seems odd that it's temperamental, but I guess I'll have to take apart the panel and start testing the bulbs individually now.
viewfindr is offline   Reply With Quote
Old 02-27-2021, 01:34 PM   #18
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 6,459
Default Re: Help diagnosing no backlight and no picture - Wasabi Mango

Sounds like a loose connection in the back lights, most likely why it works only sometimes, lots of times a tap on the tv here and there (NOT ON THE SCREEN) will temporarily make the connection and it will work till it loses contact again.
nomoresonys is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:59 AM.
Did you find this forum helpful?