Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Tablets, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-27-2022, 11:12 AM   #1
cyngo
Senior Member
 
Join Date: Jun 2015
City & State: central java
My Country: Indonesia
I'm a: Knowledge Seeker
Posts: 132
Default Lenovo Thinkpad W540 no power

please help where the problem is or if anyone has experienced please share. On the thinkpad W540, the voltage on the VINT20 drops gradually & slowly. If R380 is removed, at point DOCK_PWR20 appears voltage 20V. inject voltage on VINT20, nothing short. has been replaced mosfet Q9 and Q36, replace the processor, flash bios. but no change.
Attached Files
File Type: pdf Thinkpad W540 Wistron Kome-1 WS 12291-1 Rev -1.pdf (1.93 MB, 10 views)
File Type: rar Thinkpad W540 12291-1.rar (186.5 KB, 2 views)
cyngo is offline   Reply With Quote
Old 07-03-2022, 10:24 AM   #2
cyngo
Senior Member
 
Join Date: Jun 2015
City & State: central java
My Country: Indonesia
I'm a: Knowledge Seeker
Posts: 132
Default Re: Lenovo Thinkpad W540 no power

any suggestion?
cyngo is offline   Reply With Quote
Old 07-03-2022, 10:47 AM   #3
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 4,077
Default Re: Lenovo Thinkpad W540 no power

Hi.

1) Remove all power -> meter in resistance mode (lowest scale) -> check the resistance to ground of VINT20. What is the reading ? Also post the meter scale.

If the meter reports '1' or 'OL' (over limit) -> switch to a higher meter scale.

2) Check the first 2 mosfets for defects using the usual mosfet resistance checks.

With NO power. Meter in resistance mode.

check the resistance of each mosfet:

source (1-2-3) & drain (5-6-7-8)
source (1-2-3) & gate (4)
gate (4) & drain (5-6-7-8)

post the readings of Q9, Q36 mosfets along with the meter scale.

3) With the power on -> meter in 20v scale -> check the voltage reading of the following pins:

ACDC_IN_CONN
ACDC_IN
F2, Pin # 1
F2, Pin # 2

U7, ACDET pin # 4
U7, pin # 36 (AVCC)
U7, pin #15 (REGN)



4) Are you using a docking station ?

5) Are you using the official and original power adapter ? The ID pin on the adapter is being used to identify the presence of the original adapter so it must be used.
mon2 is offline   Reply With Quote
Old 07-08-2022, 01:22 AM   #4
cyngo
Senior Member
 
Join Date: Jun 2015
City & State: central java
My Country: Indonesia
I'm a: Knowledge Seeker
Posts: 132
Default Re: Lenovo Thinkpad W540 no power

now the 20V voltage can enter across R340 by removing Q79 and adding R504. on the power button there is also a voltage of 3.3V. But still can't be switched on. after analysis, the -PWRSHUTDOWN signal only appears shortly after the PSU is connected, after that it disappears. does that indicate if the ThinkEngine chip is faulty? Has anyone experienced it?
cyngo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:53 AM.
Did you find this forum helpful?