Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-15-2019, 12:32 AM   #1
RockMiinja
New Member
 
Join Date: Dec 2019
City & State: Portland, Oregon
My Country: United States
I'm a: Knowledge Seeker
Posts: 4
Default Philips 55PFL5601/F7 only shows white or very little color

Hi there, I was just given a Philips 55" 55PFL5601/F7 that turns on fine but the screen will only show whats on the screen in white. I tried searching but was told that the power supply board, input board, and tcon could all be the problem. I was wondering if there was a specific fuse that I could be checking or any other pointers. The only thing I could find that seemed off was the power supply board has a quiet whining coming from the center left of its board. I have a few pictures to the tv below and where I hear the sound from if they're any help. Thanks in advance for any help I can get!

https://imgur.com/a/59CJKDQ
RockMiinja is offline   Reply With Quote
Old 12-15-2019, 02:50 AM   #2
RockMiinja
New Member
 
Join Date: Dec 2019
City & State: Portland, Oregon
My Country: United States
I'm a: Knowledge Seeker
Posts: 4
Default Re: Philips 55PFL5601/F7 only shows white or very little color

So I did a little poking around with my multimeter and found that on the power board the diode D656 has 12.9v but the resistor R651 right after has little to no power going through it. I think this is causing the inverter transformer T601 to have very little power on the contacts 10-15 on the entire top row. My first guess would be that replacing the resistor would be the way to fix the board but if anyone could help me before I end up buying all the wrong parts and end up breaking it more I would appreciate it.

Also heres a quick picture of the area Im looking at if it helps at all
https://imgur.com/a/3fbCGI5
RockMiinja is offline   Reply With Quote
Old 12-15-2019, 04:28 AM   #3
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 5,397
Default Re: Philips 55PFL5601/F7 only shows white or very little color

You can measure the resistance of the resistor to confirm but it doesn't look burnt.
I think your issue is possibly a gamma issue related to the tcon. Or perhaps an issue with a component on the panel driver board.
Can we get a decent photo of the tcon. If you click "Go Advanced" Then the paper clip, you can attach photos directly here.
diif is offline   Reply With Quote
Old 12-15-2019, 12:48 PM   #4
RockMiinja
New Member
 
Join Date: Dec 2019
City & State: Portland, Oregon
My Country: United States
I'm a: Knowledge Seeker
Posts: 4
Default Re: Philips 55PFL5601/F7 only shows white or very little color

Heres a few pictures of the front of the tcon, my camera seems to blur around the edges of the picture so I took a couple towards the edges too.

20191215_103945.jpg

20191215_104020.jpg

20191215_104036.jpg
RockMiinja is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:03 PM.
Did you find this forum helpful?