Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Appliances and other Household Electronic Stuff
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-12-2022, 06:31 PM   #1
freakytiki4u
Coolest Member
 
freakytiki4u's Avatar
 
Join Date: Aug 2009
City & State: Live Oak
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 107
Default Question about a fuse from an electric fireplace

I am trying to fix my sisters electric fireplace (you know the ones with fake flames). It gets no power whatsoever! I removed the main board and I seen a fuse that says "T2A 250V" on it. Its the kind that solders into the board. My question is this: Is this a slow blow fuse? I would imagine it is due to it being in a heater but I needed to be sure before I order some from Amazon. Thanks for any info. Pics attached.
Attached Images
File Type: jpg Fuse.jpg (552.9 KB, 11 views)
File Type: jpg Fuse Closeup.jpg (115.0 KB, 18 views)
freakytiki4u is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2023
Powered by vBulletin ®
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 07:08 PM.
Did you find this forum helpful?