Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 03-10-2014, 07:43 PM   #41
apolodor2014
New Member
 
Join Date: Mar 2014
City & State: NYC
My Country: US
I'm a: Knowledge Seeker
Posts: 1
Cool Re: Sony KDL-46Z4100 another TCON problem?

Hi All
As is see postings are from 2013, but i thought to give it a shot . I have the same problem with this model Sony KDL 46 Z4100. Vertical colors lines . That's it. Should i look for this chimera of T-CON board ? Just can't afford a new TV now and i'm using a LG 32 inch as a backup...ouch .
Any feedback is appreciated .
Thank You
Attached Images
File Type: jpg IMG_3372.jpg (424.2 KB, 177 views)
File Type: jpg IMG_3373.jpg (772.7 KB, 120 views)
File Type: jpg IMG_3374.jpg (452.2 KB, 96 views)
apolodor2014 is offline   Reply With Quote
Old 03-10-2014, 07:44 PM   #42
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,373
Default Re: Sony KDL-46Z4100 another TCON problem?

To me, that looks like a bad panel.
__________________
Please do not PM me with questions! Questions via PM will not be answered. Post on the forums instead!
Free service manuals: http://www.toms-service-manuals.com/ -- 72 LED/LCD TVs, 5 monitors, 28 plasma TVs, and 2 AVR 6.1 amplifiers fixed! -- I repair Pioneer 9G Plasma Main Boards & KRP-M01 Media Receivers (PM me for info)

2 Pioneer KURO 9G, 12 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 5 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 11 LG LCD/Plasma, 18 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 1 Baird (China) LCD, 6 Bush LCDs, 22 Vestel LCDs (Best->Worst)
tom66 is offline   Reply With Quote
Old 03-22-2014, 06:57 PM   #43
Davheel
New Member
 
Join Date: Mar 2013
City & State: Sydney
My Country: Australia
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony KDL-46Z4100 another TCON problem?

I have a KDL-46EX1 with the same issue of vertical color lines, the T-con board has Sony part no. A1567986A label 1-878-182-11, cannot find a replacement anywhere, just wonder is another board with same label 1-878-182-11 but different Sony part no compatiable?
Any feedback is appreciated .
Davheel is offline   Reply With Quote
Old 03-23-2014, 11:48 AM   #44
truep
Badcaps Veteran
 
Join Date: Aug 2010
City & State: Flower mound, TX
My Country: USA
Line Voltage: 120VAC 60 HZ
I'm a: Knowledge Seeker
Posts: 362
Default Re: Sony KDL-46Z4100 another TCON problem?

Do the lines move around with the old TCON? they did on the sony where I replaced the main board. What is the number on the sticker on the TCON, I'll see if I cand the one I bought before the main board.
truep is offline   Reply With Quote
Old 03-23-2014, 08:55 PM   #45
Davheel
New Member
 
Join Date: Mar 2013
City & State: Sydney
My Country: Australia
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony KDL-46Z4100 another TCON problem?

Yes the vertical color lines move around and when you change channels or press menu on the remote.
The number on the TCON is 1-878-182-11 A1567986A YX089700A
The number on the main board is A1726506A 7050778 16411992
Thanks
Davheel is offline   Reply With Quote
Old 03-31-2014, 06:14 PM   #46
Steamy777
New Member
 
Join Date: Oct 2013
City & State: Toronto, ontario
My Country: Canada
Line Voltage: 120vac 60hz
I'm a: Knowledge Seeker
Posts: 7
Default Re: Sony KDL-46Z4100 another TCON problem?

Why does the thread end here I have the same problem as chuck not dave my tv look the same and the lines move when on cable tv was it the main board or tcon???
Steamy777 is offline   Reply With Quote
Old 08-22-2014, 01:11 PM   #47
bigbrihh
New Member
 
Join Date: Aug 2014
City & State: NY, NY
My Country: USA
I'm a: Knowledge Seeker
Posts: 3
Default Re: Sony KDL-46Z4100 another TCON problem?

hey everyone, very new to the forum, but it looks like I have found the right place to get my recently purchased and very used kdl-46z4100 back into working order. All is great with the TV but it looks like the whiteness in the video color is gone and people look orange and and the overall picture has a orange film to it. Is this the tcon board or the gamma IC (as15-f) on the board that is causing the discoloration or a problem with the back light inverter? from what ive read this issue is from the gamma IC. I can post a picture later when I get back home. I got it for $250 which I am really happy about but would like to see if I can fix the issue with a $2 chip vs a $130 board.
bigbrihh is offline   Reply With Quote
Old 09-24-2014, 09:34 AM   #48
oldguy70
New Member
 
Join Date: Sep 2014
City & State: north augusta, sc
My Country: USA
I'm a: Knowledge Seeker
Posts: 3
Default Re: Sony KDL-46Z4100 another TCON problem?

KDL-40VL160 also uses A1564648A tcon. If i connect both ribbon connectors, my tv will come on with dark blue screen, then shut off after about 10 secs.
If I disconnect one ribbon connector, the tv will come on with half white display and half normal display. This tells me there is a short on the side with the white display.
I did resistance checks comparing readings of one ribbon connector to the other. and found a shorted pin on the bad side ribbon connector. When I disconnect the ribbon cable on the bad side and read resistance, the short is on the tcon side and not the panel side of the ribbon cable.
I know this is long, but it is one way of isolating one half of the tcon and verifying that the tcon is definitely bad.
oldguy70 is offline   Reply With Quote
Old 09-24-2014, 10:15 AM   #49
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,206
Default Re: Sony KDL-46Z4100 another TCON problem?

The shorts are probably the TFT IC drivers on the flexible PCB between the LCD GLASS panel and the long PCB where the flexible PCBs are bonded to.
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809
budm is offline   Reply With Quote
Old 09-24-2014, 02:56 PM   #50
Davheel
New Member
 
Join Date: Mar 2013
City & State: Sydney
My Country: Australia
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony KDL-46Z4100 another TCON problem?

Hi everyone, an update to my vertical strip display problem, finally I obtained a replacement T-con part no. A1567986A label 1-878-182-11, put it in but the issue remains, so it is down to the main board or bad panel.
Davheel is offline   Reply With Quote
Old 09-25-2014, 06:27 PM   #51
Davheel
New Member
 
Join Date: Mar 2013
City & State: Sydney
My Country: Australia
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony KDL-46Z4100 another TCON problem?

Hi, I have attached some images of my TV display, the vertical stripes moves around, does this appears to be a bad panel? Any feedback is appreciated!
Thanks.
Attached Images
File Type: jpg TV1.JPG (995.9 KB, 97 views)
File Type: jpg TV2.JPG (1.06 MB, 64 views)
File Type: jpg TV3.JPG (996.5 KB, 54 views)
File Type: jpg TV4.JPG (1.01 MB, 39 views)
File Type: jpg TV5.JPG (1,020.3 KB, 44 views)
Davheel is offline   Reply With Quote
Old 12-03-2014, 02:20 PM   #52
blouis79
New Member
 
Join Date: Jun 2009
Posts: 5
Default Re: Sony KDL-46Z4100 another TCON problem?

Worth reading this document "Sony lcd tv tcon troubleshooting and replacement" - Google and there are multiple sources.

There is a similar but different document called "Sony tcon training manual". It shows examples of tab bond failures too.

Last edited by blouis79; 12-03-2014 at 02:22 PM..
blouis79 is offline   Reply With Quote
Old 12-03-2014, 03:02 PM   #53
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,206
Default Re: Sony KDL-46Z4100 another TCON problem?

Quote:
Originally Posted by blouis79 View Post
Worth reading this document "Sony lcd tv tcon troubleshooting and replacement" - Google and there are multiple sources.

There is a similar but different document called "Sony tcon training manual". It shows examples of tab bond failures too.
Like this?
http://www.badcaps.net/forum/showpos...4&postcount=12
budm is offline   Reply With Quote
Old 12-03-2014, 03:44 PM   #54
blouis79
New Member
 
Join Date: Jun 2009
Posts: 5
Default Re: Sony KDL-46Z4100 another TCON problem?

Quote:
Originally Posted by budm View Post
Yes. That's probably where I got them from.
blouis79 is offline   Reply With Quote
Old 12-16-2014, 10:37 PM   #55
Davheel
New Member
 
Join Date: Mar 2013
City & State: Sydney
My Country: Australia
I'm a: Knowledge Seeker
Posts: 8
Default Re: Sony KDL-46Z4100 another TCON problem?

Hi,

Have already swap T-CON, Main board, cable from Main board to T-CON, so the only thing left is panel, unless someone have other ideas, thanks.
Davheel is offline   Reply With Quote
Old 07-04-2015, 06:32 PM   #56
rpmillenium
New Member
 
Join Date: Jul 2015
City & State: texas
My Country: usa
I'm a: Knowledge Seeker
Posts: 1
Default Re: Sony KDL-46Z4100 another TCON problem?

Hey guys, I have this issue with my KDL-46z4100:

When I turn it on the image is white with a strips, and after a minute turns completely white.

Do you think it's a bad TCON? Or a bad panel?

Thanks in advance!
Attached Images
File Type: jpg first.jpg (78.8 KB, 60 views)
File Type: jpg second.jpg (60.5 KB, 47 views)
rpmillenium is offline   Reply With Quote
Old 07-04-2015, 07:01 PM   #57
xredhawk
Senior Member
 
Join Date: Jul 2011
Posts: 103
Default Re: Sony KDL-46Z4100 another TCON problem?

i have a sony with vertical lines with a burning hot gamma chip
xredhawk is offline   Reply With Quote
Old 11-02-2015, 03:00 PM   #58
husky601
Member
 
Join Date: Apr 2015
City & State: Prevost
My Country: Canada
I'm a: Knowledge Seeker
Posts: 31
Default Re: Sony KDL-46Z4100 another TCON problem?

Did someone here was able to fix it or can confirm this is the panel it self? Thanks!!
husky601 is offline   Reply With Quote
Old 11-03-2015, 11:47 AM   #59
freakaftr8
Badcaps Veteran
 
freakaftr8's Avatar
 
Join Date: Oct 2012
City & State: Folsom, CA
My Country: USA
Line Voltage: 120vac 60hz
I'm a: Hobbyist Tech
Posts: 3,720
Default Re: Sony KDL-46Z4100 another TCON problem?

I've dealt with this board a few times now. I have successfully repaired quite a few but they are no walk in the park. On those four dc/dc converter outputs you should be receiving 1.0 volts for the core voltage 3.3 volts 12 volts and 2.2 volts or something to that liking. You can test these at the outputs after each of the 4 black coils. If one DC converter voltage regulator goes bad it will drag down one of the voltages. In order to repair this you need to replace all 8 DC converters including the converter drivers on the opposite side of the board. There will be two of these one for each bank of 4. Along with that replace the 4 diodes. This should get you up and going if you're missing any voltages.

Also noise in one of the stage outputs cause all sorts of problems. Mostly the 1.0v for the cpu and the 3.3v for ddr ram.
__________________
Did I leave the soldering iron on?

Last edited by freakaftr8; 11-03-2015 at 12:37 PM..
freakaftr8 is offline   Reply With Quote
Old 11-27-2016, 05:41 AM   #60
henryczek
New Member
 
Join Date: Nov 2016
City & State: Warsaw
My Country: Poland
I'm a: Knowledge Seeker
Posts: 1
Default Re: Sony KDL-46Z4100 another TCON problem?

Hi, what you mean "opposite side of the board"? Does it mean the bottom side?
What drives those voltage regulators. Thanks.
henryczek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:00 PM.
Did you find this forum helpful?