Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Desktop Motherboards, Graphics Cards, and PC Peripherals
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 07-31-2021, 08:06 AM   #1
ss45
Member
 
Join Date: Jun 2019
City & State: Brazil
My Country: Brazil
I'm a: Knowledge Seeker
Posts: 23
Default Gtx 970 strange problem

Hi I have this gtx 970

If I plug power to pin 1(left) the gpu will not be detected.
Basically no gpu vcore, ram voltage, etc.


If I only plug number 2, vcore voltage, ram voltage all appears normally, gpu itself will appear on device manager, but of course since not both are plugged, it shows error 43

I have checked line number 1, no short at all... Which confuses me.
But when only line 1 connected, gpu vcore will read 0.07 volt

Both line 1 and 2 connected shows the same symptom..
So it has sth to do with line 1

If anyone has suggestion please let me know. Thanks
Attached Images
File Type: jpg 20210731_225825.jpg (498.0 KB, 19 views)
ss45 is offline   Reply With Quote
Old 08-01-2021, 03:01 AM   #2
dicky96
Sun Seeker
 
dicky96's Avatar
 
Join Date: Mar 2017
City & State: Sunny Gran Canaria
My Country: Spain
Line Voltage: 220V 50Hz
I'm a: Professional Tech
Posts: 1,223
Default Re: Gtx 970 strange problem

It is not unusual for the two EATX12V connectors to power different phases or different VRMs

And also I have seen some models of GPU (GTX 6x0 for example) where the Vcore VRM is powered from EATX12V and the Vram VRM is powered from the PCIe 12V.

What happens when you plug both connectors?
__________________
Follow me on YouTube
------------------
Learn Electronics Repair
https://www.youtube.com/channel/UCFX...R8UZ2vg/videos
dicky96 is offline   Reply With Quote
Old 08-01-2021, 03:09 AM   #3
ss45
Member
 
Join Date: Jun 2019
City & State: Brazil
My Country: Brazil
I'm a: Knowledge Seeker
Posts: 23
Default Re: Gtx 970 strange problem

It is not unusual for the two EATX12V connectors to power different phases or different VRMs
-> I agree with that

(Pcie 12v only) -> normal gpu vcore, ram voltage, pcie 1.0v rail ,5v , 3.3v
Gpu gets detected in device manager, but shows error 43

(Pcie 12 + external power 1) -> no gpu vcore no ram voltage
Gpu not detected in device manager.

(Pcie 12 + ext pwr 2) -> same as (pcie 12) only

(Pcie 12 + ext 1 + ext 2) -> same as (pcie 12 + ext 1)

Checked all rail pcie 12, ext 1, ext 2, normal no short

5v, 3.3v, pciex 1.0v normal resistance
ss45 is offline   Reply With Quote
Old 08-01-2021, 12:53 PM   #4
dicky96
Sun Seeker
 
dicky96's Avatar
 
Join Date: Mar 2017
City & State: Sunny Gran Canaria
My Country: Spain
Line Voltage: 220V 50Hz
I'm a: Professional Tech
Posts: 1,223
Default Re: Gtx 970 strange problem

It sounds like there could be some device or circuit used as a logical AND gate that is supposed to detect the various supply voltages are present and allow the GPU to power up - but for some reason it is giving the wrong signal? Maybe due to missing or faulty SMD resistors in that circuit.

That is a bit of an inspired guess though.

What is the history of this GPU, do you know?
dicky96 is offline   Reply With Quote
Old 08-05-2021, 01:53 AM   #5
ss45
Member
 
Join Date: Jun 2019
City & State: Brazil
My Country: Brazil
I'm a: Knowledge Seeker
Posts: 23
Default Re: Gtx 970 strange problem

thank you for your reply.

It sounds like there could be some device or circuit used as a logical AND gate that is supposed to detect the various supply voltages are present and allow the GPU to power up - but for some reason it is giving the wrong signal? Maybe due to missing or faulty SMD resistors in that circuit.

That is a bit of an inspired guess though.

-well thats unfortunate. with no schematic its a nightmare to do the tracing. i wish i had that much free time

What is the history of this GPU, do you know?
- it was working fine until few weeks ago
ss45 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:47 PM.
Did you find this forum helpful?