Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Audio Equipment
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-23-2021, 04:44 AM   #1
zen
Member
 
Join Date: Apr 2011
Posts: 67
Default Philips CDR775 part help please

Apologies for repeating thread , but incorrectly listed chip required on header & couldn't alter it .

Just a heads up , in case anyone has same issue .Problem on this dual CD unit was with the recording deck . No functions apart from turntable motor spinning very fast .

Correction , chip is SAA 7392HL

Not sure if i'm posting in the correct place .

Chip is from the servo board .

3 sellers on E BAY have it , but suspect they are all part of same company , as listings look identical .

Sent a message asking if part is Original genuine chip , but no reply as yet .

Very reluctant to buy from sellers i'm not familiar with , as have many fake & faulty parts in the past .

Can anyone help with a good source of this chip.

Have already proved chip is the issue by swapping one out from a fully working unit.

Thanks Zen
zen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:27 PM.
Did you find this forum helpful?